config vpn ipsec phase1-interface
edit "linux_vpn"
set type dynamic
set interface "wan1"
set mode aggressive
set peertype one
set mode-cfg enable
set ipv4-dns-server1 8.8.8.8
set proposal aes128-sha1 3des-md5
set dhgrp 5
set xauthtype auto
set authusrgrp "dialup_users"
set peerid "linux"
set ipv4-start-ip 192.168.10.1
set ipv4-end-ip 192.168.10.50
set psksecret preshared-key
next
end
config vpn ipsec phase2-interface
edit "linux_vpn"
set phase1name "linux_vpn"
set proposal aes128-sha1 3des-md5
set dhgrp 5
set keylifeseconds 3600
next
end
config firewall policy
edit 1
set uuid 640e95fc-92ae-51e5-7a0f-361f63fea596
set srcintf "linux_vpn"
set dstintf "internal"
set srcaddr "all"
set dstaddr "local_lan"
set action accept
set schedule "always"
set service "ALL"
next
end
config user group
edit "dialup_users"
set member "test"
next
end
config user local
edit "test"
set type password
set passwd user_password
next
end
Related Articles
Technical Note : How to configure Windows version of Shrew Soft IPSec VPN tunnel with a FortiGate
The Fortinet Security Fabric brings together the concepts of convergence and consolidation to provide comprehensive cybersecurity protection for all users, devices, and applications and across all network edges.
Copyright 2023 Fortinet, Inc. All Rights Reserved.