Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
johna-eximiusdesign
New Contributor

VPN Client stuck at 40% with certificate error

We had a PC with a working Forticlient setup that recently stopped working. It gets stuck at 40% with the error "The server you want to connect to request identification, please chose a certificate and try again (-5)." I've read all over the forum and I've already tried:

- Ensured Internet Options have TLS 1.0, 1.1 and 1.2 enabled.

- Uninstalled and reinstalled Forticlient using latest versions (7.01.0083)

- Tried to restore previously know good configuration

- Ensured there is no "hidden window" for certificate authorization*

 

The same credentials work on other PCs so the issue seems to be on one PC (have a second PC with similar symptoms but haven't triaged that one yet). From the "bad" PC, we've tried accessing multiple gateways, all get the same error. So there seems to be something awry with this PC. As far as I know we don't use any certificates, at least nothing didn't come preinstalled. It is possible when the problem first showed up that there was a popup window and we hit accidentally hit "no" on the certificate authorization, but I would have figured a clean uninstall / reinstall would have cleared that flag. It is almost like this PC corrupted itself in a way a fresh install didn't fix.

 

Any suggestions would be appreciated. We're at a loss here.

 

 

23 REPLIES 23
celliott
New Contributor

Upgraded from 6.4.8 to 6.4.9 FOS to fix a bug and am experiencing the same issue as described here. We are using SAML for login with no certificate requirement. Randomly has the error about the cert, sometimes saying VPN server unreachable, sometimes just stalls at 98% and silently fails. Open case with Fortinet but not sure where it will end-up.

vforti

Hi,

 

Did you ever get a reply from Fortinet?

We tried various client versions of the 6 and 7 branch, but could not find one that works reliably.

 

We found that if one repeats the connection attempts, one eventually gets connected.

 

Thank you

muhammad-amjad
New Contributor

I Have the solution to this issue. Follow the step to fix stuck issues and share every one 

installed offline forti client  FortiClientVPNSetup_6.4.5.1657_x64 and try the stuck issue not coming after these steps.

muhammad-amjad
New Contributor

I Have the solution to this issue. Follow the step to fix stuck issues and share every one 

installed offline Forti client  FortiClientVPNSetup_6.4.5.1657_x64 and try the stuck issue not coming after these steps.