Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
jfbueno
New Contributor II

Can't connect to IPsec VPN in Windows 11

I wasn't able to connect to an IPsec VPN through FortiClient VPN (7.0.2.0090 free) when updated to Windows 11 (build 22000), SSL VPNs were working fine. When I downgraded to Windows 10 (21h2 build 19044.1415) the IPsec VPN started working again.

 

This is the error that I got on FortiClient

 

error.png

And this is the log that I exported

 

 

 

12/28/2021 4:02:55 PM	info	sslvpn	date=2021-12-28 time=16:02:54 logver=1 id=96602 type=securityevent subtype=sslvpn eventtype=status level=info uid=19AEBE88942A48F59578C42AA765D590 devid=FCT8003159070034 hostname=DESKTOP-5BJFTJ3 pcdomain=N/A deviceip=192.168.224.1 devicemac=<redacted> site=N/A fctver=7.0.2.0090 fgtserial=FCT8003159070034 emsserial=N/A os="Microsoft Windows 11 , 64-bit (build 22000)" user=bueno msg="SSLVPN service started successfully" vpnstate=

12/28/2021 4:03:04 PM	info	system	date=2021-12-28 time=16:03:03 logver=1 id=96823 type=systemevent subtype=system eventtype=status level=info uid=19AEBE88942A48F59578C42AA765D590 devid=FCT8003159070034 hostname=DESKTOP-5BJFTJ3 pcdomain=N/A deviceip=192.168.224.1 devicemac=<redacted> site=N/A fctver=7.0.2.0090 fgtserial=FCT8003159070034 emsserial=N/A os="Microsoft Windows 11 , 64-bit (build 22000)" user=bueno msg="Checking for updates"

12/28/2021 4:04:26 PM	info	ipsecvpn	date=2021-12-28 time=16:04:25 logver=1 id=96566 type=securityevent subtype=ipsecvpn eventtype=status level=info uid=19AEBE88942A48F59578C42AA765D590 devid=FCT8003159070034 hostname=DESKTOP-5BJFTJ3 pcdomain=N/A deviceip=192.168.224.1 devicemac=<redacted> site=N/A fctver=7.0.2.0090 fgtserial=FCT8003159070034 emsserial=N/A os="Microsoft Windows 11 , 64-bit (build 22000)" user=bueno msg="loc_ip=192.168.100.2 loc_port=500 rem_ip=<vpn-external-ip> rem_port=500 out_if=0 vpn_tunnel=RS IPsec action=negotiate init=local mode=aggressive stage=1 dir=outbound status=success Initiator: sent <vpn-external-ip> aggressive mode message #1 (OK)" vpntunnel="RS IPsec"

12/28/2021 4:04:38 PM	warning	ipsecvpn	date=2021-12-28 time=16:04:37 logver=1 id=96561 type=securityevent subtype=ipsecvpn eventtype=error level=warning uid=19AEBE88942A48F59578C42AA765D590 devid=FCT8003159070034 hostname=DESKTOP-5BJFTJ3 pcdomain=N/A deviceip=192.168.224.1 devicemac=<redacted> site=N/A fctver=7.0.2.0090 fgtserial=FCT8003159070034 emsserial=N/A os="Microsoft Windows 11 , 64-bit (build 22000)" user=bueno msg="No response from the peer, phase1 retransmit reaches maximum count" vpntunnel="RS IPsec" locip=192.168.100.2 locport=500 remip=<vpn-external-ip> remport=500

 

 

 

This is a log exported after a successful connection (in W10)

 

 

12/30/2021 8:24:23 AM	info	ipsecvpn	date=2021-12-30 time=08:24:22 logver=1 id=96566 type=securityevent subtype=ipsecvpn eventtype=status level=info uid=19AEBE88942A48F59578C42AA765D590 devid=FCT8003159070034 hostname=DESKTOP-5BJFTJ3 pcdomain=N/A deviceip=<my-external-ip> devicemac=<redacted> site=N/A fctver=7.0.2.0090 fgtserial=FCT8003159070034 emsserial=N/A os="Microsoft Windows 10 , 64-bit (build 19041)" user=bueno msg="loc_ip=192.168.100.2 loc_port=4500 rem_ip=<vpn-external-ip> rem_port=4500 out_if=0 vpn_tunnel=CIEE-RS action=negotiate init=local mode=quick stage=2 dir=outbound status=success Initiator: sent <vpn-external-ip> quick mode message #2 (DONE)" vpntunnel=CIEE-RS

 

 

In this log the loc_port and rem_port are different (4500, in the other log it's 500), also the deviceip is my external IP, not a local IP (that doesn't look like an IP that my machine would be using).

 

I don't know if that's causing the problem, but it's all I can find.

 

Does anyone have any tips?

 

1 Solution
SkepticSensei

I figured out the issue. It is a Windows 11 Ethernet driver issue. 

Wifi connects to VPN, Ethernet via USB to Eth adapter works. 

I downgraded to Win10 Realtek 10.54 driver version.

That fixed the issue for me.

 

Realtek PCIe FE / GBE / 2.5G / Gaming Ethernet Family Controller Software - REALTEK

 

 

let me know if this works for anyone else. 

View solution in original post

17 REPLIES 17
SkepticSensei

Downgrade your Ethernet driver to a windows 10 driver.

That worked for me.

armandoa
New Contributor

I have the same problem. It seems to be a problem with windows 11. Any update? Thanks.

SkepticSensei

I figured out the issue. It is a Windows 11 Ethernet driver issue. 

Wifi connects to VPN, Ethernet via USB to Eth adapter works. 

I downgraded to Win10 Realtek 10.54 driver version.

That fixed the issue for me.

 

Realtek PCIe FE / GBE / 2.5G / Gaming Ethernet Family Controller Software - REALTEK

 

 

let me know if this works for anyone else. 

jfbueno

I updated the same machine, got the same problem and this hack really solved it. Thank you!

Charles77

Thank you so much! My desktop at home stopped connecting to our VPN after installing the Windows 11 22H2 update. I knew it was something PC-specific since my Dell laptop on WiFi would still connect. The driver downgrade did the trick!! Appreciate the assistance.

goneriding

Worked for me as well

theo2f

Before this answer, the only way I could connect to the VPN was via WI-FI, because cable didn't work.
After using the Windows 10 driver, in addition to connecting, the speed is MUCH FASTER.
Thank you very much!

mdilena
New Contributor

Thanks @SkepticSensei , I just downgraded to 10.54 and everything started working!