Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
gopro
New Contributor

FortiClient breaks on MacOS Sierra !

In the latest MacOS Seirra beta 5- FortiClient breaks!

I'm running version 5.2.3.370.

 

The screen shows empty content, no buttons or text.

 

Any ideas?

 

1 Solution
Jpokki
New Contributor

If the install button doesn't work, this is what worked for me.

 

-Leave the unpacking/installation process and dialog active, even if the button doesnt work: do not close it or unmount the image.

-Open Finder, then use the Go to folder promt to go /private/var/

-Search for "fctupdate"

-When it is found, open the folder and run the forticlient.dmg from there.

 

I managed to install the FortiClient this way, but sadly it didn't allow me to connect properly anymore, resulting a -104 error. But that is another issue. We just changed to macOS VPN connection after some hours of frustration...

View solution in original post

6 REPLIES 6
Mattbaldwin
New Contributor

5.2.6.385 installs and works fine for me in MacOS Sierra GM build.

ghesse

Unsuccessful running 5.4.1 on Sierra. Where would I find the version you have which works? I tried downloading 5.4.1 from the Fortinet website. I get as far as the modal with the Install button, but nothing happens when I click Install.

 

Jpokki
New Contributor

If the install button doesn't work, this is what worked for me.

 

-Leave the unpacking/installation process and dialog active, even if the button doesnt work: do not close it or unmount the image.

-Open Finder, then use the Go to folder promt to go /private/var/

-Search for "fctupdate"

-When it is found, open the folder and run the forticlient.dmg from there.

 

I managed to install the FortiClient this way, but sadly it didn't allow me to connect properly anymore, resulting a -104 error. But that is another issue. We just changed to macOS VPN connection after some hours of frustration...

ghesse
New Contributor

Jpokki, thanks for the help. Since posting, I found a link to an earlier FortiClient version (5.4.0.511) and was able to install that successfully.

 

I followed those instructions but it looks like that dmg was the 5.4.0 version. I'm now getting prompted to update to 5.4.1 but then I get a message which says 'You have no authority to get update.' when I attempt to download.

kleptomac

I found this article, according to which above steps worked with v 5.4.1. Haven't tried though.

http://www.benstegink.com/macos-and-my-apps/

 

Has anyone tried this and got it working?

ghesse

kleptomac, the instructions given at your link are quite similar to those given above by Jpokki. As for me, I ended up running the uninstaller to start from scratch. Then, I downloaded 5.4.1 from the Fortinet site, then ran the setup to the point where the Install button appears. I then searched for the .dmg in the fctupdate folder, ran it from there and I'm good.