Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
JonStarr
New Contributor

Cant stop FortiClient from starting on startup

I' m using FortiClient for VPN purposes only and dont need it running any other time. I cant get disable fortinet from starting on startup. Its getting very frustrating. I' ve followed this guide; http://kb.fortinet.com/kb/microsites/search.do?cmd=displayKC&docType=kc&externalId=FD31776   But when I go to step 2 and try to uncheck FortiClient Service Scheduler and click Apply, it automatically re-ticks itself. Anyone had this problem or know how to solve it? We use Forticlient for corporate vpn and I' m having second thoughts now.

2 Solutions
AtiT
Valued Contributor

Hi, I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me. 1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient. 2) go to command prompt and enter: net stop fortishield [ENTER] 3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now. 4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual. 5) Reboot It also worked on Win 7 32bit. Regards,

AtiT
--------------------
NSE 8, CCNP R+S

View solution in original post

ChrisFGT
New Contributor

Here's how to disable FortiClient daemon automatic startup on a Mac: Tested on: macOS 10.13.3, FortiClient 5.6.6

 

Reference materials: FortiClient Administration Guide FortiClient XML Reference Guide launchd tutorial

 

System changes made:

 

/Library/LaunchAgents/com.fortinet.forticlient.credential_store.plist Change RunAtLoad key from true to false, and add false parameter below KeepAlive key...         <key>RunAtLoad</key>         <false/>         <key>KeepAlive</key>         <false/> /Library/LaunchAgents/com.fortinet.forticlient.fct_launcher.plist Change RunAtLoad key from true to false...         <key>RunAtLoad</key>         <false/>

 

A before/after comparison of running processes after reboot will demonstrate successful changes:

 

Before, with FortiClient auto-started (with leading columns cut out for ease of display)...

$ ps aux | grep -i forti | cut -d \/ -f2- Library/Application Support/Fortinet/FortiClient/bin/fctappfw Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/Resources/runtime.helper/FctMiscAgent.app/Contents/MacOS/FctMiscAgent Library/Application Support/Fortinet/FortiClient/bin/epctrl Library/Application Support/Fortinet/FortiClient/bin/ftgdagent Library/Application Support/Fortinet/FortiClient/bin/fctservctl Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/MacOS/FortiClientAgent Library/Application Support/Fortinet/FortiClient/bin/CredentialStore

$

 

After reboot, the same grep should return zero process results (other than your grep process), and the tray icon will no longer be loaded.

$ ps aux | grep -i forti

$

 

View solution in original post

10 REPLIES 10
AtiT
Valued Contributor

Hi, I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me. 1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient. 2) go to command prompt and enter: net stop fortishield [ENTER] 3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now. 4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual. 5) Reboot It also worked on Win 7 32bit. Regards,

AtiT
--------------------
NSE 8, CCNP R+S

View solution in original post

thronk
New Contributor

AtiT wrote:
Hi, I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me. 1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient. 2) go to command prompt and enter: net stop fortishield [ENTER] 3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now. 4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual. 5) Reboot It also worked on Win 7 32bit. Regards,

Thank you so much, I was JUST dealing with this on my PC.  Had to add it for a managed client who has a Fortinet firewall and now I couldn't get it to disable the startup of the service (Invalid Parameter) it kept saying.  This did the trick beautifully!

lenci
New Contributor

AtiT wrote:
Hi, I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me. 1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient. 2) go to command prompt and enter: net stop fortishield [ENTER] 3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now. 4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual. 5) Reboot It also worked on Win 7 32bit. Regards,
Thanks! This helped.

ChrisFGT
New Contributor

Here's how to disable FortiClient daemon automatic startup on a Mac: Tested on: macOS 10.13.3, FortiClient 5.6.6

 

Reference materials: FortiClient Administration Guide FortiClient XML Reference Guide launchd tutorial

 

System changes made:

 

/Library/LaunchAgents/com.fortinet.forticlient.credential_store.plist Change RunAtLoad key from true to false, and add false parameter below KeepAlive key...         <key>RunAtLoad</key>         <false/>         <key>KeepAlive</key>         <false/> /Library/LaunchAgents/com.fortinet.forticlient.fct_launcher.plist Change RunAtLoad key from true to false...         <key>RunAtLoad</key>         <false/>

 

A before/after comparison of running processes after reboot will demonstrate successful changes:

 

Before, with FortiClient auto-started (with leading columns cut out for ease of display)...

$ ps aux | grep -i forti | cut -d \/ -f2- Library/Application Support/Fortinet/FortiClient/bin/fctappfw Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/Resources/runtime.helper/FctMiscAgent.app/Contents/MacOS/FctMiscAgent Library/Application Support/Fortinet/FortiClient/bin/epctrl Library/Application Support/Fortinet/FortiClient/bin/ftgdagent Library/Application Support/Fortinet/FortiClient/bin/fctservctl Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/MacOS/FortiClientAgent Library/Application Support/Fortinet/FortiClient/bin/CredentialStore

$

 

After reboot, the same grep should return zero process results (other than your grep process), and the tray icon will no longer be loaded.

$ ps aux | grep -i forti

$

 

View solution in original post

aleckgt

1. You should also modify the file com.fortinet.forticlient.fct_launcher.plist

 

<key>RunAtLoad</key> <false/>

 

Thanks very much for your help!

mcooper

I have FortiClient VPN on Windows 10. When I (after shutting down the software) run Windows PowerShell as administrator and type net stop foritshield, all I get is this:

 

The service name is invalid.

 

Any tips?

NetworkIP_Technology
New Contributor

you have to stop forticlient to start with windows. just go to : Control Panel\All Control Panel Items\Administrative Tools\System Configuration\Startup and unselect  schedule vpn client.

mcooper

I'm afraid it isn't listed there...

gr8jam
New Contributor

I found a way to disable auto start in Linux. Sudo rights are needed.

To shutdown FortiClient:

systemctl stop forticlient-scheduler

To disable the auto start at the next boot:

systemctl disable forticlient-scheduler