Several approaches to capture clear text of HTTPS packets

® Chrome DevTools
® Firefox Web Developer
® Fiddler Web Debugger

1. Chrome DevTools
If you are using Chrome browser, please press 'F12' to open DevTools. see below:

&  C | # GitHub, Inc. [US] | https//github.com

How people
builld software

click 'Network' label to open 'Network' panel. Here we can get insights into requests and response

traffic of the web pages.

We can get the clear text information even if the packet is encrypted. For example, open the

'https://www.github.com' url, we can see all the packets interacted with the server.
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click one item in the panel. We can see the details in the right panel. See below, it's a GET request

example.



Name

I_| github.com I

u frameworks-c07e6f4b02b556d1d85052fb3853cafB4cB0e6b23dcdblaelb00f051dalll5aZ.css
u github-4d14493830801 ffc6d6d6363f3fcef8abed1fd9e74776dce]5fa2c18b2a9bbT2.055
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[] eollect

u page_view?dimensions[page]=https%3A%2F%2Fgithub.com%2F&dimensions(titie]=How3%20people320build%20software...

18 requests | 662 KB transferred | Finish: 5.77s | DOMContentloaded: 2.185s | Load: 4.27s

A POST request example:

* | Headers | Preview Response Coockies Timing

¥ General
Request URL: https://github.com/join
Request Method: POST
Status Code: @ 200 OK
Remote Address: 192.3@.253.112:443

» Response Headers (21)

¥ Request Headers view parsed
POST /join HTTP/1.1
Host: github.com
Connection: keep-alive
Content-Length: 218
Cache-Control: max-age=@
Origin: https://github.com
Upgrade-Insecure-Requests: 1

Content-Type: application/x-www-form-urlencoded
Referer: https://github.com/

Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.8

ZMWEIMJ IyZjR1YmI1NDY@OGYxZmQiLCIFY3NyZ198b2t1biI6ImZiQ2p:
! jcaf 0% el

¥ Form Data view parsed

We can also get the post body 'Form Data' in the panel.

Accept: text/html,application/xhtml+xml,application/xml;q=9.9,image/ webp,*/*;q=0.8

wWhXdKQT loblBFeldCZnFrugh5Q
b g 4

X | Headers | Preview Response Cockies Timing

¥ General
Request URL: https://github.com/
Request Method: GET
Status Code: @ 200 OK
Remote Address: 192.38.253.112:443

4 Response Headers (20) |
Request Headers view parsed

GET / HTTP/1.1

Host: github.com

Connection: keep-alive

Pragma: no-cache

Cache-Control: no-cache

Upgrade-Insecure-Requests: 1

User-Agent: Mozilla/5.@ (Windows NT 6.1; Win64; x64) Applelebkit/537.36 (KHTML, like @
Accept: text/html,application/xhtml+xml,application/xml;q=8.9,image /webp,*/*;q=0.8
Accept-Encoding: gzip, deflate, sdch, br

Accept-Language: en-US,en;g=9.8

Cookie: logged_in=no; _gh_sess=eylzZXNzalIuX21kIjoiNTUyOTViYjUwYmQzMWELM] IyZFR1YmI1INDY
nU@RzdYb@hvcBcwUTAVUGBIInB%3D--6117ad293d1F877a74b3acebfd2%e>fd77d45ce>; _ga=0Al.2.884
sia%2FShanghai

User-Agent: Mozilla/5.@ (Windows NT 6.1; Wing4; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.8.2848.9% Safari/537.36

Cookie: logged_in=no; _octo=GH1.1.1228578324.1484276100; _pga=GA1.2.B84395312.1484276100; tz=Asia%2FShanghai; _gat=1; _gh_sess=eylzIXNzaklduX
215WnUeRzdYb@hveBowlTAVUGBIL iwicmVmZXIyYuxfY2SkZSI6ImhadH

utfB=%E2%9C%938authenticity_token=TgNbidkeTnlZI¥YKgONPYBmy sMVIIWFLsXQdMelxPoIEY97oF n1t@rkimBldGyvnXFYpSbBcEBiSamBrzZz ) FFg%30%3D&user¥5Blogl
1%50=test12348user¥SBpassword®5D=G&source=form-home

Please reproduce the issue, and check the packet which triggered signature 030000138 and record

the whole packet information.



2. Firefox Web Developer
If you are using Firefox browser, please press 'F12' to open Web Developer. see below:

|| Pseann

(i) @ GitHub, Inc (US) - hitps:github.com

O Personal Open source  Business Explore

Pricing  Blog  Support Sign ir

R L} Inspector 2 Console @ Debugger [} Style Editor € Performance
o m HTRL €35 IS ¥HR  Fonts  Images Media Flash Other
Status Methad File Darnain Type Transferred Size 0ms TRdms  1.28s 192

A 301 GET I @ ww.github.com hitrril 7.69 KB KB . - 265 ms

® 200 GET i/ & github.com htrnl 1.69 KB 25.2TKB - 49ms

® GET framewvarks-c0Te6fab02bS56d1d85052fb3853cafd4cdefb2Idedbla.. @ assets-cdn.github.corm =33 2102 KB 100,22 KB I~ 47ms

® 200 GET github-4d 144938308 01ffc6dfd6363f3fcefiafe1fddeT4TT6dcel5fal.,. @ assets-cdn.github.com (23] 95.72 KB 41387 KB N~ 62ms

® 200 GET site-293f92180d026192 750Fa2bSeaeleI6T40FS723a59c0ec308972c70... @ assets-cdn.github.com css 11.45KB 58.52 KB I+ 3ms

® 200 GET 2 home-ill-build.png?sn @ assets-cdn.github.com png 5.99 KB 5.99 KB B -78ms

® 0 GET " horme-ill-work.png?sn & assets-cdn.github.com prg 11.23 KB 1123 KB ~ Oms

® 200 GET = home-ill-projects.pngisn & assets-cdngithub.com png 10.08 KB 10.08 KB - 0ms

® GET 8 horme-ill-platform.png?sn @ sssets-cdn.github.com png 7.5 KB T899 KB -~ 0ms

® 200 GET + | org_exarnple_nasa.png?sn & assets-cdn.github.com prg 94.92 KB 94.92 KB ~ Dms

® GET frarewworks-bb39ae Td848dA0d6f0 167355 282964F54Fa39 137 cleccs.. @ assets-cdn.github.corm s 8307 KB 23476 KB i —~48ms

® 00 GET github-4def3f491231325b0a39aec54463c 246e4547995b501718504d... @ assets-cdn.github.com 15 146,08 KB 489,11 KB I~ 32ms

® GET W home-hero jpatsn B assets-cdn.github.com peg 113.26 KB 1326 KB |- 16ms

® 200 GET rohoto-regularwoff @ assets-cdn.github.com z-fant-woff 12.00KB 12.00 Ke - Oms

® GET roboto-mediumawoff @ assets-cdn.github.com z-fart-woff 12.94 KB 1294 KB | + 16 ms
click 'Network' label to open 'Network' panel. Here we can get insights into requests and response
traffic of the web pages.
We can get the clear text information even if the packet is encrypted. For example, open the
'https://www.github.com' url, we can see all the packets interacted with the server.
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® GET m harne-herajpg?sn @ assets-cdn.github.cam jpeg 113.28 KB 11328 KB | = 16ms
® GET roboto-regularwoff B8 assets-cdn.github.com x-font-woff 13.00 KB 13,00 KB ~ Oms
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click one item in the panel. We can see the details in the right panel. See below, it's a GET request

example.




R CFInspector 2 Console @ Debugger  {} Style Editor € Performance

d BEW HTML css US XHR  Fonts  Images  Medis  Flash  ther

A

Sis  Metnod Fie - params Respe
01 GET ; & wonvgithub.com  Request URL: https: //github. com/

Request method: GET

Remote address: 192. 30, 253.113:443

200 GET Frameworks-c07e6fab02b55601d85052fb3953cafaace0ebba3dedbla.. @ assets-cdn.github.co Status code: @ 200 0K

200 GET github-4d144938 3080163633 ceffatedlfdde T4 Thdcel5fa2.. @ assets-cdn.github.co Yersiom: HTTR/1.1

200 GET site-203f02180d03610a750fa2b5eae0e36 740157235 0c 0ec303872c70., @ assets-cdn.github,co - Iiterheaders

200 GET = home-ill-build.pngisn @ assets-cdn.github.co_* Response headers (1988 KE)

200 GET * home-ill-work.prg?sn @ 3ssets-cdn.github.co

200 GET <= home-ill-prajects.pngisn @ assets-cdn.github.co

n . 2] home.illpltformngism @ 2ssets-cdn qithub.co User-Ag:ant: “MozillafS.0 (Windows NT 6.1; WOWE4; rv:47‘[I)Gecknﬂ[ll[l[l%[llFlrefnx/fil[l"
Accept: "text/html 3pplication/zhtml +xml,application/xmlg=0.3q=0.0

200 GET © org_sample_nasa.pngiin 8 assetscdngithubc0  accapt-language: "en-US enyq= 5*

200 GET Framemorks-bb30ae Td8 4804006/ 1e67335e 28206 4547239137 cleccd... @ assets-cdn.githubco  Accept-Encoding: "gzip, deflatz, bt

200 GET github-4de6Af49123133f5k 038 9aecT 44690246 45479080 B91F18504d,.. @ assets-cdngithub.co  Connection: "keep-alive”

200 GET I horne-herojpgisn @ s3sets-cdn.github.co

200 GET robota-reqularwoff @ 3ssets-cdn.github.co

200 GET roboto-mediurm.woff @ assets-cdn.github.co

200 GET roboto-lightawaff & assets-cdn.github.co

200 pPOST collect & wonv.google-analyti

200 GET page_viewidimensions[page]=httpsi//github.com/&idimensio.. @ collector.githubapp.

204 OPTIOMNS  stats B8 apigithub.com

200 POST stats & spigithub.com

POST request example:

Cookies Params Response Tirmings Security Previe

Request URL: {53 github.com/
Request method: POST

“® Remote address: 192,32, 253.112: 443
0 Status code: @ 200 OF Edit and Resend  Raw headers
co Yersion: HTTP/ 1.1
ca Filter hzaders
co ! Response headers (2,182 KE)
#ir 7 Regquest headers (0,720 KE)
p Host: "github.com”
i User-Agent: "Mozilla/3.0 (Windows NT 6,1 WOWGS,; red7. 00 Gecko/20100101 Firefox/47.0"
Accept: "text/html applicationhtm|+zmlapplicationfamlg=0.9,%™g=0.8"
P! Accept-Language: "en-US,eriq=0.5"
Accept-Encoding: "gzip, deflate, br"
Referer; "https:/fgithub.corms™
Cookie: "logged_in=no; _gh_sess=eyZZNzaWI w2k oV TOxMZFINYF mMNDMIND gz 28 3ZGYiIVZESOT., 4279606, _octo=GHL 11499986203, 1484279606, tz=~merica®2Flos_Angeles; _gat=1"
Connection: "keep-alive”
* Request headers from upload strearm (0L064 KB)
Content-Type: "application-waa-form-urlencoded”
Content-Length: "203"
we can get the post body in 'Parms' label.
B e s s L
Headers Cookies Response Timings Security Preview
Fitter reguest porometers
~ Farm data
utfl: "
authenticity_token: "11Fybn7/51+j6 Clbb 2L Ryt BraWK Qo AFp Sk F srglEOKHrdSFHpt1tnd0 7 TRa) pHoll + W TdrSdFe CZRMDagDUY ) =="
user[login|

Pl

user[email]: "a"

user[password]:
source: "forrn-home"

ease reproduce the issue, and check the packet which triggered signature 030000138 and record

the whole packet information.



3. Fiddler Web Debugger

1) Download link: https://www.telerik.com/download/fiddler
Install the software and run it, see below

[ Teterik Fiddler Web D
File Edit Rules

_a b | el
GeoEdge

“J 4+ Replay X~ ¥ Go ¥ Strear Decode | Keep: All sessions = & Any Process # Find [l Save | I8 ) @ Browse + Gk Clear Cache /T TextWizard [H Tearoff MSDM Search. & & Online X
#  Re. Pro. Host URL Body Cac.. Conten... Pracess| @ Statistics |4 Inspectors | # AutoResponder| [ Composer | o) Log | [ Filters | = Timeline| 1 APITest
01 200 HT.. vwww.fiddler2.com [UpdateCheck.aspx?isBeta=... 785 private text/pla...

Select one or more sessions in the web Sessions 1ist to view performance statistics.

Join the Telerik Fiddler Insider program and get involved in creating the product
roadmap and testing new features - http://bit.ly/Fiddlersurvey

Show Chart

2) Config Fiddler to capture packet
click [Tools] -> [WinINET Options], 'Internet Properties' is opened:

‘:’i Internet Properties @
| General I Security | Privacy | Content | Connections | Programs I Advanced

Ta set up an Internet cannection, click
Setup.

Dial-up and Yirtual Private Network settings

Add...
Add VPN, ..
Remave. ..
Choose Settings if you need to configure a proxy Settings
server for a connection,
(@ Never dial a connection
Dial whenewver a netwaork connection is nat present
Always dial my default connection
Current Mone Set defaul:

Local Area Metwork (LARN) settings

LAM Settings do not apply ko dial-up connections. LAM settings

Choose Settings above For dial-up settings.

click 'LAN settings' and config as follows:


https://www.telerik.com/download/fiddler

G’l Local Area Metwark (LAM) Settings @

Automatic configuration

Automatic configuration may override manual settings. To ensure the
use of manual settings, disable automatic configur ation.

[Tiautomatically detect settings:

|:| Use automatic configuration script

Proxy server

a proxy server for your LAN {These settings will not apply ko

idl-up or YPM connections).

[ | Bypass proxy server For local addresses

QK ][ Caniel ]

U Proxy Settings @

Servers
| 8 Twpe Proxy address to use Port
>
HTTF: G555
Secure: 127.0.0.1 . BEEE
FTP:
Socks:
[T Use the same proxy server for all protocols
Exceptions
[ B Do not use proxy server for addresses beginning with:
L8
<-loopback= -
Use semicolons { ; ) ko separate entries.,
[ [0]4 ] [ Cancel

click 'OK'.

click [Tools] -> [Telerik Fiddler Options] -> [Connections], set the Fiddler listens on port 8888.
It is according to the Internet LAN setting listening port.

Telerik Fiddler Options (5]

General I HTTPS | Connections | teway | PP ce I E i I Performance I Tools |

Fiddler can debug traffic from any application that accepts a HTTP Proxy. &1l WinINET traffic is routed
through Fiddler when "File > Capture Traffic" is checked.

Learn more...
Fiddler listenson port: 8888 [ Act as system proxy on startup
TOPY Browser Proxy conniguration one Manitor all connections [ Use PAC Seript
[ Capture FTP requests [F] DefaultLan
VPN HEH

|| Allow remote computers to connect [Cven ik
Reuse client connections
Reuse server connections Bypass Fiddler for URLs that start with:

<-lpopback>; -

Help Mote: Changes may nottake effect until Fiddleris restarted. QK ] [ Cancel




3) Config Fiddler to capture HTTPS traffic
click [Tools] -> [Telerik Fiddler Options] -> [HTTPS], configurations as follows:

Telerik Fiddler Options [=]

| Generall HTTPS |Connectior|s | Gateway | Appearance | Extensions | Performance | Tools |

Fiddler can decrypt HTTPS sessions by re-signing traffic using seff-generated certificates.

Capture HTTPS CONNECTs

Decrypt HTTPS traffic

[...fmmall processes - Certificates generated by CertEnroll engine

Ignore server certificate errors (unsafe)

Check for certificate revocation
Protocols: <client=; ssl3;tls 1.0

Skip decryption forthe following hosts:

Help Mote: Changes may nottake effect until Fiddleris restarted. (0] 4 ] [ Cancel

When you tick the "Decrypt HTTPS Traffic" checkbox, we will see a prompt:

SCARY TEXT AHEAD: Read Carefully! 3]
iiﬁi To intercept HTTPS kraffic, Fiddler generates a unique root certificate.

‘ou may configure \Wwindows ko trust this root certificate to suppress
security warnings. This is generally safe.

Click "fes' to reconfigure Windows' Trusted Ca list,
Click "Ma" if this is all geek ko wou,

Trust the Fiddler Root certificate? ¥es ] [ Mo

click 'Yes', the following prompt is:
Security Warning J

You are about to install a certificate from a cerification authority (CA)
l % claitning to represent:

DO_MOT_TRUST FiddlerRoot

Windows cannot validate that the certificate is actually from
"DO_MOT_TRUST_FiddlerRoot". You should confirm its origin by
contacting "DO_NOT_TRUST_FiddlerRoot". The following nurmber will
assistyou in this process:

Thurbprint (shal): 936FBAAL 2A845FD3 42D77TA4F 93545DEF
9BEAADDZ

Wfarning:

If you install this root certificate, Windows will autormatically trust any
cettificate issued by this CA&, Installing a certificate with an unconfirmed
thumbprint is a security risk, If you click "Yes" you acknowledge this
risk.

Do youwant to install this certificate?

Yes | MNao |

click 'Yes' to install Fiddler certificate.

4) Open the Web site using Internet Explorer browser, now we can get all the traffic captured by



fiddler. Click the packet in the left panel, and the detail is in the right.

Take 'https://github.com/' as an example, the HTTPS packet is decrypted.

O Telerik Fiddier Web Debugger e — - - | i
Eile Edit Rules TYools View Help Iﬁddlﬂ £ GeoEdge

[Z]¢ Replay X+ » Go ' # Stream [ Decode | Keep: All sessions - & Any Process # Find [l Save 1% (@ & Browse - < Clear Cache /T TextWizard & Tearoff MSON Search. & & Online X
# Re.. Protocol Host URL Body Cac.. Conten.. Pr{ & AutoResponder | ¥ Composer | - ﬁml——nmdml 7 APITest

#1 200 HTTP Tunnel to github.com:443 0 e Meades W rms | HexView | Auth | Cookies JSON XML

$2 200 HTTP Tunnel to github.com:443 0 ied [GET https: /égnh m/ HTTP/1.1

€3 200 HTTP xml.th.sogou.com /xml.jsp?query=gi&h=F27A... 928 max... text/x.. sof [HOSt: git

Connection: keep-a

®4 200 HTTP vind.ie.sogou.com /s?h=F27AF453303288C68... 203 text/pla... sof Accep; text/html, apphcanon/thuxﬂ application/xm1;q=0.9,image/webp, */*;q=0.8
#5 200 HTTP Tunnel to github.com:443 0 »f [Upgrade-Insecure-Requests:
15 - HTTP Tunnel to_dients1.google.com:443 1 h User- Agent: Mozilla/5.0 (windows NT 6.1; wow64) ApplewebKit/537.36 (KHTML, like Gecko
17 HTTP Tunnel to dlients1.google.com:443 1 ol [Accept-Encoding: gzip, deflate, sdch
te HTTP Tunnel to dlients1.google.com:443 -1 o ANQUAGR: ZHoIN 201G
google. g -0Ct0=GH1.1.2055607115.1479024529; logged_in=yes; dotcom_user=Betweener; _ga=C
#9 200 HTTP Tunnel to sp1.baidu.com:443 0 ie
Z10 200 HTTPS spl.baidu.com /5b1ZeDeSKgQFm2e88IuM 0 image/gif ie
#11 200 HTTP Tunnel to_github.com:443 0 0
f12 - HTTP Tunnel to dients1.google.com:443 -1 ch
@13 502 HTTP Tunnel to_www.google.com:443 582 _no-c... text/ht.. sof |« o v
REi14 200 HTTI github.com / 164 no-C... text/ht.. so BEEENrE=erR=rgere ) |[Viewinnateoad
15 200 HTTP Tunnel to assets-cdn.github.com:443 0 04 "Get SyntaxView  Transformer Headers TextView | ImaceView HexView WebView Auth  Caching
#16 200 HTTP Tunnel to assets-cdn.github.com:443 0 sof Cookies [Raw ~ JSON | XML
17 200 HTTP Tunnel to avatars0.githubusercontent... 0 sof [TTP/1.1 200 OK =
M18 200 HTTP Tunnel to assets-cdn.github.com:443 0 s0f se:ver& ?ﬂ:abJ 01710710576 (T
&10. 4 o | [pate: Fr an
19 200 HTTP Tunnel to assets-cdn.github.com:443 0 sof [eantento pe: Text/htal; charset-utf 8
t20 HTTP Tunnel to dients1.google.com:443 1 chf |status: 200 ok
21 HTTP Tunnel to dlients1.google.com: 443 1 h 5:'532'&?:5;:1: no-cache
£22 - HTTP Tunnel to diients1.google.com:443 1 onf |x-UA-compatible: IE=Edge,chrome=1
£23 - HTTP Tunnel to dients1.google.com:443 1 hf |Set-Cookie: user sesslon=unu Suszzl QU_y7qv49sP_jwl6-; path=/; e
Set-Cookie: St E1 7qva49sp
X! kequgst 1d: fl8eh6b97549ae1a2848e290c9645ee5
X-Runtime:

Content- securi(y Fohc¥ default-src 'none'; base-uri 'self'; block-: a'll mixed-conten

Strict-Transport-Security: max-age=31536000; includesubdomains; prelo

Public-Key-Pins: max-age=5184000; pin- shazss-“wownyxovnahhanunsc?anHvs9vvmc.oxud
;10“5' nosniff

en

3 mode-lﬂo:k

VZI’y' Accept EI’|C0 g

IX-Served-By: Se?dz 41ba49dfdb3929780833971c

X~ Gunub -Request-Id: 3D958FE2:6F44:12EE8645:58787C28
Content-Length: 60164

<!DOCTYPE html>

<htm] lang="en" c'lass-" 15 u2f-enabled">

<head prefix="og: ‘'ogp.me/ns# fb: http://ogp.me/ns/fb# object: http://ogp.me
<meta charset=' tf
<meta content="origin-when-cross-origin" name="referrer" />

(press CurleEnter to hghight o) [viewinnoteoad

Please reproduce the issue, and check the packet which triggered signature 030000138 and record
the whole packet information.



