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Introduction 
PKI authentication is the methodology used to verify the identity of a user by checking the validity of the 
certificate bound to that user.  It is an alternative to traditional password based authentication. The 
traditional method is based on “what you know” – the password, while PKI authentication is based on 
“what you have” – the private key related to the certificate.   A common weakness of traditional 
password based authentication is the vulnerability to password guessing or brute force attack. PKI 
authentication is more resilient to this type of attack hence provides a stronger authentication 
mechanism in this sense.  

In cryptography, a PKI is an arrangement that binds public keys with respective user identities by means 
of a certificate authority (CA). PKI authentication relies on two factors: 

1. The tree of trust.  If a CA is trusted, then all the certificates issued by this CA or any intermediate 
CA trusted by this CA are trusted (Certificate Revocation List (CRL) or Online Certificate Status 
Protocol (OCSP) is used to handle revoked certificates and not covered in this document) 

2. Public key encryption algorithm. The data encrypted by public key can only be decrypted by 
private key. This is the basis for asymmetric data encryption. Similarly the data encrypted by 
private key can be decrypted by the public key. This is usually used for digital signature. The 
private key is only available to a specific individual, while its related public key is embedded in 
the certificate signed by a CA. Before communication starts, two parties exchange certificates 
and verify if the certificate is issued by a trusted CA, if the claimed identity matches the one in 
the certificate, if the certificate has expired and if the certificate type/usage matches the 
intended usage in the certificate. Since the certificate is freely available, digital signature is used 
to verify that the request did come from the party who owns the certificate.  

 
The architecture of PKI authentication on FortiMail is described in the diagram below: 
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Generally speaking, there are six steps to enable PKI authentication on FortiMail as following: 

1. Create user certificates and Import into browser 
2. Import the CA certificate on FortiMail 
3. Create domain and local users on FortiMail server 
4. Create PKI user 
5. Create incoming policy and enable PKI authentication for webmail access 
6. Enable PKI authentication on CLI on FortiMail 

Step 1: Generate the required certificates 
This step has two objectives: 

• Obtain the CA certificate in base64 encoding (DER encoding is not supported in FortiMail version 
4.0 GA and MR1). 

• Generate end user certificates that meet the following  two requirement: 
A.  Email address in CN field (or Alternative Subject Name) that will be used as the login ID 
B. The type of certificate should be accepted by the browsers for client authentication. Usually 

TLS or SSL web client certificate or certificate without any type at all will work for most 
browsers. FortiMail doesn’t check the type of certificate, so this check is enforced by the 
browser on client side. 

The certificate can be generated with Microsoft Windows Certificate Service, OpenSSL or any other 
third-party CA, as long as it meets the requirements set above. Usually the certificate sign request (CSR) 
is generated on the end user PC so that the private key doesn’t have to be exported/imported. 
Alternatively, a CSR can be generated by administrator on behalf of all end users. Then the private key 
and the signed certificate have to be exported by administrator and transmitted to end users who then 
import into their browsers. All the user certificates and related private keys (usually in PKCS12 format) 
have to be delivered to end users and stored securely. If someone else obtains the private key and 
certificate, he/she can impersonate that person and gain unauthorized access. If more than one 
browsers are used, the PKCS12 file needs to be imported into all the browsers separately because 
different browsers don’t share the certificate store. 

 For instructions on how to generate certificate on Windows Certificate Service 2003, please refer to 
Appendix A. 

Step 2: Import the CA certificate on FortiMail 
To make FortiMail trust a CA, you must import the CA certificate obtained in step 1 into FortiMail by 
going to System > Certificate > CA certificate. 
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Step 3: Create local domain and users  
If the FortiMail unit is deployed in gateway mode or transparent mode, email users whose email is 
quarantined on FortiMail are created automatically. And the email users can only access the Bulk folder 
which contains the quarantined spam in their web mail.   

If the FortiMail unit is deployed in server mode, you must manually create local email users. The email 
users can access all the folders available on the server. Besides, in FortiMail version 4.0.4 and later 
releases, only local users (server mode) are supported for PKI authentication. External LDAP users are 
not supported for PKI authentication. 

Step 4: Create PKI users 
For webmail PKI authentication, PKI user is a template used to specify how FortiMail validates a 
certificate. The administrator needs to select the CA of which the certificate was imported in step 2. If a 
field is left empty, it means FortiMail won’t check this field. So if the administrator doesn’t specify the 
CA, FortiMail will accept the certificates issued by any CA, which is a security hole. An internal or 
external attacker could set up a private CA and create a certificate for any email address he/she wants 
to attack and then gain unauthorized access into the mailbox with the certificate signed by his/her own 
CA. 

To create a PKI user: 

1. On the FortiMail web UI, select User > User > PKI User, and then click New.   

2. Give the PKI user a name, say “foobar.com”.  

3. Select a domain in the drop-down list.  

4. Remember to leave the subject field empty. Because the subject field of each individual user is 
different, we need to leave this field in the PKI user empty to match all the user certificates. Later 
on, the subject can be configured to restrict access to a subset of users, for example ou=IT. 
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FortiMail can also retrieve a certificate stored in LDAP directory. For simplicity, this document doesn’t 
cover this. 

 

Step 5: Configure policies to enable PKI authentication  
Click Policy > Recipient Policy, check “Enable PKI authentication for web mail spam access” and select 
the PKI user template created in step 4. Click “ok” to confirm the change. There is another setting called 
“Certificate validation is mandatory” that may be enabled based on users’ specific requirement. If this 
setting is not enabled, the system can fall back to traditional password based authentication if 
certificate-based authentication doesn’t succeed. If this setting is enabled, users have to provide a valid 
certificate to gain access to web mail. 
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Step 6: Enable PKI authentication globally on CLI 
The last, but not the least, is to enable PKI authentication globally on CLI. The setting configured in step 
5 is domain specific and won’t work until PKI authentication is enabled globally. 

In the FortiMail CLI console, type the following command: 

config system global 

 set pki-mode enable 

end 

After this, when end users try to access the web mail, they should be prompted for certificates. If users 
are not prompted, it may be because the FortiMail HHTP server has not loaded the new settings yet. You 
can use the CLI command “exec reload” to manually enforce reload of the configuration. 

Step 7: Test PKI authentication 
To test whether PKI authentication works, end users type the URL of the webmail on their browsers. The 
end users should be prompted for certificate confirmation like below: 
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If the end user clicks OK, the user will be able to log on to the web mail as below: 

 

Appendix: Generate User Certificates with MS CA 
This section describes how to use MS Certificate Service 2003 to generate user certificates that can be 
used for PKI authentication on FortiMail. The default certificate template coming with MS 2003 CA 
doesn’t work. A customized template has to be created. Because Windows 2003 server standard doesn’t 
support the customization of certificate template, so Windows Server 2003 Enterprise edition is 
required. 

1. Install MS CA with web enrollment on Windows 2003 Enterprise Server.  
2. On Windows 2003 server,  run MMC and add “Certificate Template” and “Certificate 

Authority” snap-ins. 

 
 

3. Select “Certificate Templates” and right click “User” in the right pane. Then select “Duplicate 
Template”. 
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4. Fill in the template name, validity period and renewal period according to your specific 
requirement on the “General” tab.  

 
5. On “Request handling” tab, select “signature and encryption” for Purpose. 
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6. Select “Supply in the request” on the “Subject Name” tab because the default subject name 

doesn’t work with FortiMail.  

 
7. Enable “Enroll” permission for administrator on the “Security” tab 
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8. On the “Extensions” tab, make sure “Client Authentication” is enabled for “Application 
Policies” (client authentication is enabled by default).  

  
 

9. On the “Superseded Templates” tab, select “User” template on which this new template is 
based. 
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10. Leave other settings as default, and click “OK” to create the new template.  
Then the Certificate Authority needs to be configured to issue certificate with the new 
template just created. 
 

11. Select “Certificate Authority” on MMC. Right click “Certificate Templates” under the root CA 
and select “New > Certificate Template to Issue”. 

  
 

12. Select the new template just created from the list and click OK. 
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Now the administrator need to use web enroll to create certificates for all the users as 
following: 
 

13. Type http://your_ip_of_ms_ca_server/certsrv/ and login in as administrator 
This document assumes all certificates are requested by administrator on behalf of end 
users. 

 
 

14. Click the last option “Download CA certificate”, and then select “Base64” for CA certificate 
encoding. Click “Download CA certificate” and save the CA certificate.  

http://your_ip_of_ms_ca_server/certsrv/�
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15. Click Back button of the browser to return to the welcome page of certsrv as shown in step 
13. Click “Request a certificate”, click “Advanced certificate request”, then click “Create and 
Submit a request to this CA”.  

 
 

16. Select the new template created previously and fill in the information for subject. Please 
note that only the name field is required and it needs to match the email account set up on 
FortiMail. FortiMail will use the email address either in Name (Common Name) or 
Alternative Subject Name field as the login ID. Alternative Subject Name is not supported by 
default in MS CA 2003. For simplicity, we used Name field in this document. The full name of 
this user can be added as the optional “friendly name”. 
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17. Then click “Submit” to submit the certificate request. 
 

18. If CA is configured to issue the certificate automatically, you will see “Install the certificate” 
link on the web page soon after the certificate request submission. Click this link to load 
your certificate into your certificate store. 

 
 

 
19. On your browser (IE 7 in this document), select Tools > Internet Options > Content > 

Certificates.  
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20. Select the certificate we just created in the list and click “Export” to export it to a file so that 
end user can import into their browser.  

 
21. On the certificate export wizard, please remember to export the private key together with 

the certificate: 

 
 

22. Configure password to protect the private key and certificate.  
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23. Name the PPCS file, say user1@foobar.com in this document, and click “Finish” to export 

the certificate and private key. 
 
Now the user certificate should be transported to end user securely. End user needs to 
import the certificate/private key into their browser. 
 

24. End user open their browser ( IE 8 in this example), select Tools > Internet Options > Content 
Certificates.  

 
25. Click “Import” on “Personal” tab. Then select user1@foorbar.com.pfx , supply the same 

password as configured by administrator when exporting this certificate/private key and 
import the certificate into “Personal” certificate store. 

mailto:user1@foobar.com�
mailto:user1@foorbar.com.pfx�
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Now the certificate preparation is done. Next step is to configure FortiMail to enable PKI authentication 
for web mail access. See detailed instructions in the early section of this document.  
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