Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
josebash
New Contributor

sslvpn vdoms to vdom-links

Device  Fortigate 100F, v7.4.1
Can someone help me please?

I followed this guide 
https://community.fortinet.com/t5/FortiGate/Technical-Tip-SSL-VPN-access-to-multiple-VDOMs/ta-p/2237...

 

To create VDOMs and has their own sslvpn.

The only difference on my setup is that since I'm using SNAT instead of using the DNAT name I'm using the internal IP in the destination of the policy firewall.

 

https://107.xxx.186.174:10443   doesn't work. It is like  fortigate is not forwarding correctly.

vdom-link0  (10.198.45.1)

vdom-link1 (10.198.45.2)

 

Root and the new vdom can  ping both IPs above.


on root vdom:

edit 4
set name "SSLVPNFLAUNTin"
set uuid b5097f20-a692-51ee-9fe8-eb8cc2148214
set srcintf "wan1"
set dstintf "Vdom-Flaunt0"
set action accept
set srcaddr "all"
set dstaddr "10.198.45.2/32"
set schedule "always"
set service "ALL"
set logtraffic all
set groups "VPN Users"
set comments " (Copy of SSLVPNCFT)"
next


Policy on new VDOM:

 

edit 1
set name "SSLwebVPNin"
set uuid ea2fbc84-a695-51ee-ddb6-069ecb3f5a23
set srcintf "Vdom-Flaunt1"
set dstintf "vlan45"
set action accept
set srcaddr "all"
set dstaddr "10.198.45.2/32"
set schedule "always"
set service "ALL"
set logtraffic all
next

 

ROOT DNAT & VIPs:

 

config firewall vip
edit "FlauntSSLvpn"
set uuid e7b7f854-a6cc-51ee-26f3-10ce781f191b
set extip 107.xxx.186.174
set mappedip "10.198.45.2"
set extintf "wan1"
set portforward enable
set extport 10443
set mappedport 10443
next
end

 

 

Can you tell me what I'm doing wrong, please?




 

1 REPLY 1
funkylicious
SuperUser
SuperUser

Hi,

Please try like this:

 

- on root VDOM ( internet facing VDOM ) , create a VIP for the VDOM-link interface towards VDOM-A IP ( which later will be referenced in the SSLVPN settings on VDOM-A )

e.g. inter-vdom link : root VDOM - 10.198.45.1/24 and VDOM-A - 10.198.45.2 /24 ( this last IP will be used in the VIP)

 

- use that VIP in the firewall rule in root VDOM : srcintf wan1 , dstintf vdom-link , srcip any, dstip VIP, NAT active ( use outgoing interface ip ) 

 

- in VDOM-A configure the SSLVPN to listen on the IP/interface of VDOM-link ( 10.198.45.2 /24 )

 

- in VDOM-A configure the firewall policies for SSLVPN with group etc, in order to activate the SSLVPN

 

This should do the trick

geek
geek
Labels
Top Kudoed Authors