Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rezafathi
Contributor II

schedule not working

Hi,

 

I have created a schedule as follows and assigned it to a policy but after time reaches to 06:00 PM the policy do not disable.

 

config firewall schedule recurring
    edit "DNat Schedule"
        set start 08:00
        set end 18:00
        set day sunday monday tuesday wednesday thursday friday saturday
        set color 6
        set fabric-object disable
    next
end

 

Reza F.
Reza F.
1 Solution
hbac

Hi @rezafathi

 

The firewall policy is not supposed to be disabled. When out of the schedule, traffic will not match that policy. Have you tested the actual traffic? Also make sure the FortiGate is running on the right time zone. 

 

Regards, 

View solution in original post

5 REPLIES 5
pavankr5
Staff
Staff

Hello @rezafathi, It looks like you're trying to create a schedule for a firewall policy that should disable after 6:00 PM, but it's not working as expected.

> Could you please confirm if you have any other policies with same source and destination.

> Try to access internet after 6PM and check the forward logs to see if it is taking any other policy to go out.

> Verify that the device's time settings are accurate and aligned with the local time. If the device's time is incorrect, the schedule may not activate or deactivate at the intended times.

let us know if you have any queries.

 

Thanks,

Pavan

rezafathi

the time is ok. i moved the policy on top and again it did not disable.

Reza F.
Reza F.
sw2090
Honored Contributor

what do you mean if you say "disable"?

 

In fact in policy view a policy will not be disabled once out of schedule. However it will not match any traffic if it doesn't have a valid schedule.

 

-- 

"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

-- "It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams
rezafathi

you mean when the time is over the policy won't disable and it just won't pass the traffic?

Reza F.
Reza F.
hbac

Hi @rezafathi

 

The firewall policy is not supposed to be disabled. When out of the schedule, traffic will not match that policy. Have you tested the actual traffic? Also make sure the FortiGate is running on the right time zone. 

 

Regards, 

Labels
Top Kudoed Authors