Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Not applicable

routing IP to wrong interface

hi, i have a strange thing. my system is FW-100A V3.0MR7P2 from client(A) i can ping server(P resides outside in the www) -> ok from client(B) no answer at ping to server(P) clientA and clientB are in the same interface and subnet... debbunig shows me, the FW routes the IP from client(B) to a different wan!! ping client(A): 4.491298 clients in 10.63.228.132 -> 147.88.205.171: icmp: echo request 4.491390 wan1 out 147.88.254.102 -> 147.88.205.171: icmp: echo request 4.492210 wan1 in 147.88.205.171 -> 147.88.254.102: icmp: echo reply 4.492295 clients out 147.88.205.171 -> 10.63.228.132: icmp: echo reply 4.492311 internal out 147.88.205.171 -> 10.63.228.132: icmp: echo reply ping client(B) 16.703695 clients in 10.63.228.161 -> 147.88.205.171: icmp: echo request 16.703822 wan2 out 147.88.219.238 -> 147.88.205.171: icmp: echo request wait... 22.028493 clients in 10.63.228.161 -> 147.88.205.171: icmp: echo request 22.028523 wan2 out 147.88.219.238 -> 147.88.205.171: icmp: echo request all other services like www, ftp, smtp, etc. work ok for both client... any glue of that strange routing?
4 REPLIES 4
rwpatterson
Valued Contributor III

I believe if you have two equal routes with the same distance, cost, and priority, the FGT will divide the traffic between the two based on odd/even IP addresses. Give that a test, and see.

Bob - self proclaimed posting junkie!
See my Fortigate related scripts at: http://fortigate.camerabob.com

Bob - self proclaimed posting junkie!See my Fortigate related scripts at: http://fortigate.camerabob.com
Not applicable

hmmm... yes, i do have two equal wan-routes. both have a default route to the next hop with same distance... if i differ one wan-distance, all clients packet will sent out to wan1 which is correct. BUT i have e webserver on dmz2 and those packets will be sent out to wan1 which is not correct. i have a policy route dmz2 -> wan2 but this will not work.. unless i set the distance on all wan to the same value. remember, since firmware release 2.08 MR12 it was working this way... looking forward for any hints... thnx. claudio
rwpatterson
Valued Contributor III

I am no pro on dual WAN since I don' t have that setup (yet). Maybe someone else can give you more guidance...

Bob - self proclaimed posting junkie!
See my Fortigate related scripts at: http://fortigate.camerabob.com

Bob - self proclaimed posting junkie!See my Fortigate related scripts at: http://fortigate.camerabob.com
romanr
Valued Contributor

Setting the distance for upstream routes tothe same value is correct! On the CLI (command-line-interface) you will also find a " route priority" value! Setup the route priority lower on the link you want to use by default and for the rest use policy routes to force them to the other interface! That' s all! Additionally I' d setup ping-servers as well -> then automatic takeover will happen as well! cheers.roman
Top Kudoed Authors