Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
storaid
Contributor

how to give the ON-Net status to DHCP client via external DHCP server??

hello, fortinet and everyone...

I know using code 224 option sends S/N to DHCP client and make client using FCT keep On-Net status...

but it's good working only for dhcp server function with fortigate...

 

I'm using windows dhcp server...

the windows dhcp server does not send it to client during dhcp prcoess even if you added this option on DHCP Standard options by setting predefined options ....

the code 224 option is not dhcp standard option, it's just a private-use option...

my question is

how to send this option which belong to a set of vendor-specific extension to dhcp client???

FWF60D x2 FWF60C x3 FGT80C rev.2 FGT200B-POE FAP220B x3 FAP221B x2

FSW224B x1

18 REPLIES 18
Christopher_McMullan

I personally don't have any more answers about that.

 

Opening the question up to the wider (monitoring) community...

 

Otherwise, there's always Stack Exchange.

Regards, Chris McMullan Fortinet Ottawa

storaid

Christopher McMullan_FTNT wrote:

I personally don't have any more answers about that.

 

Opening the question up to the wider (monitoring) community...

 

Otherwise, there's always Stack Exchange.

hello, I don't understand why...

but now dhcp client can correctly receive option 224 from dhcp server...

 

dhcp client<==> FSW224B-POE<==>FGT200B-POE

dhcp server<=====||

I just try the following steps:

1. enable dhcp snooping (default: diabled)

2. disable dhcp snooping, again

3. done, and test again..

 

FWF60D x2 FWF60C x3 FGT80C rev.2 FGT200B-POE FAP220B x3 FAP221B x2

FSW224B x1

ylemage_FTNT
Staff
Staff

Hi,

 

Any idea what the value should be in case of a FortiGate cluster? We are talking about 2 SN's. Can we put both? How should they be seperated?

 

Brgds

Yves

kolawale_FTNT

Put both FortiGate serial numbers in the configuration. The separator is either space or semicolon.

--

Consider creating a new Forum posting when your question is different from the original posting (as in this case).

mstenner
New Contributor

Hi,

 

I am experiencing a similar issue. Did you manage to resolve?

 

Thanks,

 

Martin

bgillon
New Contributor

Dear,

 

can you explain how to configure dhcp option on windows server ?

did you have create string, byte array ?

i try with my serial number of (Fortigate or FortiEMS) but on-net is not detected by forticlient ?

 

regards

mstenner

1. Set a predefined option for each DHCP server of Option ID 224 with a name of FortiClientStatus. It needs to be a string and an array (select the tickbox).

For the array values, enter the serial number(s) of your FortiGates.

2. Apply the new option to the required scope.

 

See screenshot for example.

bgillon

perfect.

it's works ;)

CoSax
New Contributor

What serial number should be entered in DHCP option 224 when you use Forticlient EMS and not a Fortigate?