Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
gateberg78
New Contributor

WAN Connection on FortiSwitch, PPPoE not connecting

Hello,

i have a Fortigate 80F and a Fortiswitch FS124 in front of it in managed mode. All working fine with 7.4.1

 

I want to connect the ISP via a Port on the FS124 and do the required PPPoE there.

 

Setup

  • The ISP WAN Line is connected to my designated Port on Fortiswitch and the Port has the following Native VLAN assigned.
  • On the fortilink interface, there is a VLAN (ISP assigned VLAN ID) as WAN configured and also the PPPoE there, but i cannot get the PPPoE get connected. Status Failed.

 

Doing exactly the same setup on any port of the Fortigate works perfectly fine.

 

Doing the troubleshooting (https://community.fortinet.com/t5/FortiGate/Technical-Tip-Troubleshooting-PPPoE-connection-failed/ta...) for PPPoE with a diag i can see, that PADI is send, but no PADO coming back.

 

What am i missing here?

 

Update:

I have sniffed .cap traces for both setting PPPoE on the Firewall and on the Switch:

  • 80F: PADI --> PADO ... all visible and ok Screenshot 2023-12-11 at 09.58.29.png
  • FS124E: PADI --> no responseScreenshot 2023-12-11 at 10.00.47.png


I have also setup PPPoE on another Fortigate 80F and it is working fine. There must be something switch related.

2 REPLIES 2
AEK
Honored Contributor

Hello

Can you try this?

config system global
  set hw-switch-ether-filter disable
end
AEK
AEK
gateberg78
New Contributor

80F # config system global

80F (global) # set hw-switch-ether-filter disable

command parse error before 'hw-switch-ether-filter'
Command fail. Return code -61
Labels
Top Kudoed Authors