Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Marcde_J
New Contributor II

Virtual Server - Outlook > Exchange

Please can someone urgently assis.t

 

I have upgrade to os 7.4 on my 200E.

 

Created virtual servers for my internal setups.

 

The Virtual Server for Microsoft Exchange / Email connectivity (HTTPS) works perfectly on mobile (IOS, Android)
But refuses to work on Outlook ? 

No errors in logs etc. Any ideas?

9 REPLIES 9
abarushka
Staff
Staff

Hello,

 

I assume that MS Outlook is configured to use other protocol than https. Therefore, you may need to configure another virtual server for different protocol. 

FortiGate
Marcde_J
New Contributor II

The only protocol is HTTPS, and MAPI over HTTPS.

In my same setup with a Virtual IP the firewall policy with only service enabled being HTTPS works just fine?

abarushka

Hello,

 

You may consider to sniff traffic on FortiGate (Microsoft Exchange facing interface) and try to reproduce the issue. It will give you a hint, whether TCP/TLS session was established successfully.

FortiGate
Marcde_J
New Contributor II

I see on 7.4.1 cli there is:
set outlook-web-access enable|disable

I upgraded however still cannot set it on CLI?
command parse error. I assume the above would fix my issue?

abarushka

Hello,

 

I can see such setting in case of https virtual server:

 

config firewall vip
edit "abc"
set type server-load-balance
set server-type https
set extip a.b.c.d
set extintf "any"
set extport abc
config realservers
edit 1
set ip a.b.c.d
set port abc
next
end
next
end

 

 # set outlook-web-access
disable Disable Outlook Web Access support.
enable Enable Outlook Web Access support.

FortiGate
Marcde_J
New Contributor II

Hello. Yes. My issue is that i get the following error when trying to configure:

set outlook-web-access

command parse error before 'outlook-web-access'
Command fail. Return code -61

abarushka

Hello,

 

outlook-web-access setting availability depends on the configuration. I posted sample configuration in the previous message.

 

FortiGate
mle2802

Hi @Marcde_J,

Can you please make sure that you are making changes for the virtual server not virtual IP? I have tried with type is HTTPS and the command is available.

Regards,
Minh

Marcde_J
New Contributor II

Hi All. We are revisiting this issue with our new 200F firewalls.

We have observed the same behaviour when changing from VIP to Virtual Server - and can see the connection gets reset on POST from outlook trying to get the Autodiscover XML file.

Not sure if this provides any further Clarity or help in trying to get this solution to work?

 

Top Kudoed Authors