Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
mkhawaja
New Contributor

VPN assigned DNS servers do not show up in resolv.conf

I am running Ubuntu 22.10 and Forticlient 7.0.7.0246.   When I establish VPN, name resolution does not work.  I see the problem is that VPN DNS addresses are not showing up in the resolv.conf file as well as the search suffixes.  I have created a script that after establishing VPN, I copy over resolv.conf with a resolv.conf that has the correct DNS servers and search suffixes.   Once I disconnect, the resolv.conf is restored to the original file.

When connected to VPN, resolvectl shows the correct addresses:

ink 3 (wlp2s0)
Current Scopes: DNS
Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 10.200.11.69
DNS Servers: 10.200.11.69 10.104.3.23

 

Note that above does not show the search suffixes which are assigned by the VPN server.

 

Resolution test fails when I run the following with message "resolve call failed: 'name.mydomain.org' not found:

resolvectl query name.mydomain.org

 

My resolv.conf has the following entries:

nameserver 192.168.0.1
options edns0 trust-ad
search .

2 REPLIES 2
Anthony_E
Community Manager
Community Manager

Hello,


Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible.


Thanks,

Anthony-Fortinet Community Team.
srajeswaran
Staff
Staff

You may be hitting a known issue,it says Red Hat, not sure if Ubuntu is also affected/tested.

 

https://docs.fortinet.com/document/forticlient/7.2.0/linux-release-notes/254811/known-issues

876539 FortiClient on Red Hat 9 cannot resolve domain name properly using DNS server that SSL VPN pushed.
Regards,

Suraj

- Have you found a solution? Then give your helper a "Kudos" and mark the solution.

Top Kudoed Authors