Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
jdubrull
New Contributor

Use a proxy on mgmt interface to request trial license

Hello,

 

I want to request a permanent trial license with fortigate, but I need access to internet for that from my FW. I have a proxy to go out and I don't find any way to configure a proxy on my interface to request the trial online.

 

What is the way please ?

 

 

Thank you,

5 REPLIES 5
jdubrull

Isn't it just for updates ?

abarushka

Hello,

 

That KB is referring to license verification + UTM updates.

 

For regular traffic you may consider to follow KB below (proxy chaining):

 

https://community.fortinet.com/t5/FortiGate/Technical-Tip-How-to-configure-web-proxy-forwarding-serv...

 

FortiGate
jdubrull

Thank you, but still not functional.

 

I had to enable web-proxy explicit because for the proxy-policy there is the line set proxy explicit-web.

 

config web-proxy explicit
    set status enable

 

But at the end, I got proxy:null when requesting license. See picture attachedScreenshot 2023-11-30 174620.png

 

 

My conf is:

 

config web-proxy forward-server
  edit "fwd-srv"
    set addr-type fqdn
    set fqdn "hidden"
    set port 80
  end

 

config firewall proxy-policy
  edit 1
    set uuid e5aa4778-8f9e-51ee-5328-8b5a7d31eefb
    set name "proxy"
    set proxy explicit-web
    set dstintf "port2"
    set srcaddr "all"
    set dstaddr "all"
    set service "webproxy"
    set action accept
    set schedule "always"
    set webproxy-forward-server "fwd-srv"
  end

 

 

config web-proxy explicit
  set status enable
  set http-incoming-port 8080
end

 

Problem is my proxy port is 80 but I can't config 80 on explicit proxy

abarushka

Hello,

 

There is a DNS error. Have you already configured "config system autoupdate tunneling"?

FortiGate
Labels
Top Kudoed Authors