Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Ginger_Badger
New Contributor

Unable to install FortiClient 5.4 on Windows 7 SP1 x64

I get a 'driver is not digitally signed' error for each of the services it tries to install. 

 

No option to 'continue anyway', followed by a roll back. 5.2 installs fine.

 

5.4 has installed correctly on my Mac. Any ideas before I tackle another 50 machines?

1 Solution
Ron_Uss
New Contributor III

Hi

check this - https://technet.microsoft.com/en-us/library/security/3033929

FortiClient 5.4.0 use digital signing SHA-2 and for Windows 7 SP1 and Windows XP you need install this update.

 

Info from Forticlient Release notes:

Installing on Windows 7 and Windows XPFortiClient 5.4.0 files and drivers are digitally signed using SHA2 certificates. Microsoft Windows 7 and Windows XP are both known to have issues with the verification of SHA2 certificates. Ensure your Windows system software updates are up-to-date before installing FortiClient 5.4.0 on either of these two platforms. 

NSE8 #3111

View solution in original post

NSE8 #3111
14 REPLIES 14
adil
New Contributor

I get this error.

Please install windows patch kb 3033929 before installing forticlient.

bryan1
New Contributor

I have the same issue.  When trying to install patch windows says the patch is no longer suitable for this machine.  As in the patch has already been installed.

To clarify, I try to install the client 5.4 on a windows 7 pro x64.  The client says need kb3033929 to be installed. I download and install the patch.  The patch says that the patch is no loner suitable for this machine. I look up logs it shows that the patch is already installed.

 

bryan1
New Contributor

Was able to install Forticlient 5.6 on Windows 7 pro x64 sp1 traditional chinese.  However when trying to install the same client on Windows 7 pro x64 sp1 simplfied chinese, have same message cannot install unless kb3033929 patch is installed. When checking logs and installed patches it shows that the patch has already been installed. Tried manually installing the patch the patch says the patch is unsuitable for this computer. Tried using both the automatic installer, and the offline installer.

flppds
New Contributor

the patch can be installed only in Win 7 SP1 

 

credits to

[size="2"]http://www.ceccherini.net/fortinet-vpn-client-errore-installazione-windows-7-kb3033929/ [/size]

RamadaLucknow

Uninstall all Previous Windows Updates -> restart OS-> Install KB3033929 -> resolved

thank you

Top Kudoed Authors