Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
marek7
New Contributor II

Support for FortiClient VPN 7.4 for Ubuntu 24.04 LTS

I was not able to install forticlient on Ubuntu 24.04 LTS 

 

 

 

~/Downloads/vpn $ sudo dpkg -i forticlient_vpn_7.4.0.1636_amd64.deb
Selecting previously unselected package forticlient.
(Reading database ... 234015 files and directories currently installed.)
Preparing to unpack forticlient_vpn_7.4.0.1636_amd64.deb ...
Unpacking forticlient (7.4.0.1636) ...
dpkg: dependency problems prevent configuration of forticlient:
forticlient depends on libappindicator1 (>> 0) | libayatana-appindicator1 (>> 0); however:
Package libappindicator1 is not installed.
Package libayatana-appindicator1 is not installed.

dpkg: error processing package forticlient (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1.1ubuntu3) ...
Processing triggers for desktop-file-utils (0.27-2build1) ...
Errors were encountered while processing:
forticlient

 

 

 

I found package "libayatana-indicator7_0.8.4-1+deb11u2_amd64.deb"

but I was not able to install it on Ubuntu 24.04.

 

Do you support FortiClient VPN 7.4 for Ubuntu 24.04 LTS?

 
9 REPLIES 9
AEK
SuperUser
SuperUser

Try install one of them (libappindicator1 or libayatana-appindicator1).

I think there is no need to install both.

AEK
AEK
abelio
SuperUser
SuperUser

Hello marek7,

As you can check in FC 7.4 release notes: ( https://docs.fortinet.com/document/forticlient/7.4.0/linux-release-notes/136392/product-integration-...
Ubuntu 24 it' s not officially supported/integrated in this version.

 

So, try AEK's approach first; 
if your issue persists, try to repack Forticlient in your station in order to change libindicator dependencies.   How to (Debian related, but similar for Ubuntu) you could see this external (to this forum) link
https://unix.stackexchange.com/questions/723131/installing-forticlient-vpn-on-debian-bullseye-versio...

Let us know if you were be able to sort this out. 

regards




/ Abel

regards / Abel
marek7
New Contributor II

Thanks @AEK I installed libappindicator1 from ubuntu repository, it helped.

Anyway FortiClient should support Ubuntu 24.04 out of the box it is LTS version.

AEK

CLI:

apt install libappindicator1

 Or on GUI you can use your favorite software manager.

AEK
AEK
AEK

Then try install libayatana-appindicator1

AEK
AEK
marek7

I download it from ubuntu here:

https://packages.ubuntu.com/jammy/amd64/libappindicator1/download

but now it is down maybe temporarily...

AEK

I tested on Linux Mint 21.3 (it is also ubuntu/debian) and the libappindicator1
package was installed from the official Mint repo without any issue.

The problem is that FortiClient VPN is not supported by Fortinet (I mean you will not get support from TAC support).

So I think you should post the issue on Ubuntu forum, I'm sure they can help with installing that package from an official repo.

Besides I don't recommend (at all) to install from unofficial repo.

AEK
AEK
miciti
New Contributor III

According to https://www.fortinet.com/support/product-downloads/linux they are still on ubuntu 22.04 LTS

jeremy-mordkoff
New Contributor

i found that openfortivpn works well on Ubuntu 24.04. It took a little extra work to get MFA to work. But I do prefer a command line client anyway 

Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors