Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
iaityahia
New Contributor II

Setting DHCP Server for PXE boot

hello

 

I want to configure the DHCP server of my 80F  firewall, for this purpose I need to set options 60, 66 and 67,especially for options 67 I can't set it via the web interface, it recamnds me to use the CLI console.

i followed this technical tips 

Technical Tip: Configure DHCP option 60, 66 and 67... - Fortinet Community

 

But when I run a command bellow a get  "Attribute 'interface' MUST be set."   and "Command fail. Return code -56", 

config system dhcp server

    edit <>

        set filename {string}

    next

 end

how and where to set the interface attribute, I tried with set interface "interface_name"  ?  but it doesn't work

1 Solution
AEK
Honored Contributor

So I guess you should edit the 3rd, like this:

config system dhcp server

    edit 3

        ...

AEK

View solution in original post

AEK
6 REPLIES 6
AEK
Honored Contributor

Hello

It is the interface on which this DHCP server config will run.

The easiest is to configure it via GUI then go to CLI, there you will find the configuration ready, then just add what you need to add via CLI.

AEK
AEK
iaityahia
New Contributor II

yes the interface is UP and running, with GUI, and th DHCP is ready, when I try to set option 67, i have a warning, with CLI it tell me to set interface attribute  

This option may not function correctly. It should be set using the CLI attribute: filename.

Fortigate.png

Bellow my console commande suit 

 

Fortigate # config system dhcp server

Fortigate (server) #
Fortigate (server) # edit 1
new entry '1' added

Fortigate (1) #
Fortigate (1) # set filename "E:\\RemoteInstall\\Boot\\x64\\wdsnbp.com"

Fortigate (1) #
Fortigate (1) # next
Attribute 'interface' MUST be set.
Command fail. Return code 1

Fortigate (server) #
Fortigate (server) # end

 

AEK
Honored Contributor

Please share this output:

show system dhcp server

AEK
AEK
iaityahia
New Contributor II

the output is 

Fortigate # show system dhcp server
config system dhcp server
    edit 2
        set ntp-service local
        set default-gateway 169.254.1.1
        set netmask 255.255.255.0
        set interface "fortilink"
        config ip-range
            edit 1
                set start-ip 169.254.1.2
                set end-ip 169.254.1.254
            next
        end
        set vci-match enable
        set vci-string "FortiSwitch" "FortiExtender"
    next
    edit 3
        set dns-service default
        set default-gateway 192.168.1.1
        set netmask 255.255.255.0
        set interface "internal"
        config ip-range
            edit 1
                set start-ip 192.168.1.20
                set end-ip 192.168.1.160
            next
        end
    next
end

Fortigate # 
AEK
Honored Contributor

So I guess you should edit the 3rd, like this:

config system dhcp server

    edit 3

        ...

AEK
AEK
iaityahia
New Contributor II

yes it's work i editing th wrong one, I'm new in the fortigate world 

thank's for help 

Labels
Top Kudoed Authors