Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Alex88
New Contributor

Route vpn ipsec comes from port mgmt

Hey, everybody!
anyone have any experience? I set up an ipsec tunnel between FG and AWS. The tunnel is up, static route and policies are in place. Ping from aws to fg is pinging. but from fg to aws is not.
I started looking, I saw an outgoing ip during the ping from the management port. although it is not even connected. there is no such route. even if I turn off the mgmt port, traffic to the tunnel still comes from it. I put 0.0.0.0.0/0 on the mgmt port.
Now traffic started coming from FortiLink port (802.3ad Aggregate), also disabled port, also put 0.0.0.0.0/0 ip on it. now traffic went to vpn tunnel from wan port. How can this be fixed? I don't have such routes, does fg make them up by itself)?

model 400F - os v7.2.6

1 Solution
ezhupa
Staff
Staff

Hello Alex88, 
if you are pinging directly from the Fortigate with "execute ping x.x.x.x" then the  FortiGate is forwarding traffic with outgoing interface IPsec tunnel, and the tunnel does not have an overlay IP, the FortiGate is selecting the physical interface with the smallest index as source IP.
You can refer to the below article:
https://community.fortinet.com/t5/FortiGate/Technical-Tip-Source-IP-for-self-originating-IPsec-tunne...

You should be able to ping with the source method as explained by my colleague syordanov. 

View solution in original post

4 REPLIES 4
syordanov
Staff
Staff

Hello Alex88,

 

How do you generate the traffic from your 400F towards AWS ?

Do you generate that traffic using ' execute ping x.x.x.x' from FG or that icmp is generated from host behind your FG 400F?

My advise is to check the local encryption domain of your FW and pick one IP address from that range and specify as a source IP for the ICMP on FG :
execute ping-options source x.x.x.x   <--- where x.x.x.x is the IP address part of your local encryption

execute ping y.y.y.y <--- where y.y.y.y is the host behind AWS

 

 

Best regards,

 

Fortinet

.
ezhupa
Staff
Staff

Hello Alex88, 
if you are pinging directly from the Fortigate with "execute ping x.x.x.x" then the  FortiGate is forwarding traffic with outgoing interface IPsec tunnel, and the tunnel does not have an overlay IP, the FortiGate is selecting the physical interface with the smallest index as source IP.
You can refer to the below article:
https://community.fortinet.com/t5/FortiGate/Technical-Tip-Source-IP-for-self-originating-IPsec-tunne...

You should be able to ping with the source method as explained by my colleague syordanov. 

Alex88
New Contributor

FG makes up the routing table itself when it can't explicitly determine the source address. When you ping from fortik, it doesn't have a source address on the interface and takes from the "first" one that comes up (you can argue the logic, but that's how it's done), that port could be mgmt and the mgmt port will be disabled. Traffic will come from this interface. It is necessary to assign an IP to the interface for the tunnel.

 

Question solved! Thank you for answering me!

 

PS - links that have helped me 

https://community.fortinet.com/t5/FortiGate/Technical-Tip-Configure-IP-address-on-an-IPSec-tunnel-in...

https://community.fortinet.com/t5/FortiGate/Technical-Tip-Source-IP-for-self-originating-IPsec-tunne... 

 

 

ezhupa

Hello Alex88, 

Perfect, glad we could be of help. 
You can also select one of the comments as a solution so in case another community member who has the same query/issue can find the solution quickly.

Top Kudoed Authors