Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

Possibe Solution/Work around for Win11 VPN not connecting

Good afternoon everyone!


Came across an issue today and I think I found the problem, and a work around solution.

A few people I have seen have this issue, so I wanted to post my results in case anyone else needs them.


Original Issue: Forticlient (ipsec) VPN not connecting on Windows 11


After some troubleshooting, I found that the VPN would work only over Wifi and not via Ethernet.

I then tested a USB to Ethernet adapter, and it was able to work.
So I narrowed the issue down to the onboard Ethernet driver.
Driver was up to date, so I did the typical uninstall/reinstall, Did not work.
However I knew my Windows 10 machines worked flawlessly.


Solution: I was on Realtek driver version 1168, So I decided to try downgrading the Wifi driver to 10.54.
That fixed the issue.


It seems the problem is related to the newest Realtek Ethernet drivers, at least it was for me.
I don't know if other brands have the issue too.


I wanted to get this information out there for anyone who needs it, and so Fortinet can be made aware of the issue to look into Driver compatibility problems.


If you have this issue, and this resolves it for you, please let me know, I am curious to see if this fixes for everyone with the issue.



New Contributor

I have had great success resolving this issue with the Realtek driver version downloaded directly from Realtek

Hope this helps others.


Thank you! I've had to download WIN10 Driver instead of WIN11 driver from Realtek Website in order to make it work, because Win11 driver version still has the same issue, but it was version 10.65 (win10 Auto Install NDIS download from realtek website) still works and it's newer than my HP driver from HP support website for my laptop. Thank you!

Mr. Mash'Up!
Mr. Mash'Up!

Dear SkepticSensei,
Thankyou for providing the information at this portal. Hope this information would be helpful for other users who are using the latest Realtek driver version 1168.


New Contributor II

Can we have details on the precise bug affecting the RealTek driver?


We are enterprise customers of Dell, which uses this chipset accross various pieces of equipment and redistributes the drivers. Although RealTek might not pay close attention, I wonder if I could bring this up to Dell instead, maybe they could see about getting this fixed or providing a workaround.



Manager, IT Operations and Security
Manager, IT Operations and Security
New Contributor

I'm also seeing this issue and reached out to Realtek support who have been very helpful.

They have requested various logs which I have provided, so hopefully they can use this information to establish the root cause and possibly develop a new version of the driver which works with Forticlient.

I have a workaround for the Windows 11 driver version which is to set the driver architecture to NDIS in the registry:

1) Find the driver service key : Device Manager > Network Adapters > Realtek USB GbE Family Controller > Properties > Details > Change drop down to 'Service' and note down the value.

2) In registry : "HKLM\System\CurrentControlSet\Services\*driver service key value*\Parameters" - configure DrvNetArch to 0 which changes the architecture from NetAdapterCx to NDIS.

3) Reboot to apply change


Thank you! I was just trying your solution using the updated driver that Windows 11 installs from Windows Update, but that "DrvNetArch" does not appear in my device registry:




so I added it manually (create DWORD, set DrvNetArch as name, then set value to 0) and now I am restarting to see if the solution works.

EDIT: Nope, it doesn't work :( By creating manually that registry DWORD doesn't connect, same error as before (VPN failed error message). I have installed driver version 1168.13.424.2023 from Windows 11 Update (auto-updated by selecting devide > search for driver updates), so I'm reverting once again to the driver version I know it works (until windows decides to update it one more time haha).

Mr. Mash'Up!
Mr. Mash'Up!
Top Kudoed Authors