Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
navin_cool
New Contributor

No reports generating (No matching log data) after upgrading to 4.3.8

Hi,

Recently we have upgraded

Fortigate 200A Firewall from 4.2.2 to 4.3.18

Fortianalyzer 1000B from 4.2.2 to 4.3.8

 

Before the upgradation, all reports are showing data and worked well in FAZ.

After upgradation, I have noticed below issues

1. No matching Log data (No Data) in all repots 2. Unnder Report-->Layout is not visible/available in GUI 3. Under Report-->Schedule is not visible/available in GUI

 

When I do SQL Query test/run, I see below error ERROR: operator does not exist: timestamp without time zone >= integer. LINE 1: select ((case when itime_start >= 1458766800 and itime_end <...

 

Logs are reaching to FAZ, since I can see real time traffic logs All Policies are enabled with "Log data" option In Fortigate Firewall, all logs are send option is enabled towards FAZ

 

 

I think it must be an issue with SQL database, but I am not sure how to fix it.

Can any one of you help me to resolve this issue.

 

1 Solution
abelio
Valued Contributor

 

That seems to be corrupted database during the upgrade process

Check it with TAC to be sure.

 

 

 

regards




/ Abel

View solution in original post

regards / Abel
4 REPLIES 4
navin_cool
New Contributor

Can any of you help me to address this issue, please

abelio
Valued Contributor

Hello,

Let assume you upgraded your  FTG200A  from 4.2.2 to 4.2 patch 16 and from there to 4.3.18

And for your FAZ 1000B  running 4.2.2 is trickier: there were a lot of changes and enhancements to the SQL between 4.2.2 and 4.2.6.

Faz running 4.2.6 enable to go to 4.3.8, not prior ones.

 

If that was not the update path,  i'd recommend a clean format for your FAZ, flash and disk and load a fresh 4.3.8 image through  TFTP.

 

 

Consider also go further and evaluate SQL logging with your  FAZ running 5.0.12

Hope it helps

 

 

 

 

 

regards




/ Abel

regards / Abel
navin_cool
New Contributor

Hello Abel,

Below is the upgrade path followed

FGT200A 4.2.2---4.2.13---4.3.6---4.3.11---4.3.18

FAZ1000B  4.2.2---4.2.6---4.3.8

 

can you please check the error mentioned in my initial post and suggest the possible reason for it.

 

abelio
Valued Contributor

 

That seems to be corrupted database during the upgrade process

Check it with TAC to be sure.

 

 

 

regards




/ Abel

regards / Abel
Labels
Top Kudoed Authors