Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Newimage
New Contributor

Multicast help

Hi I' m trying have VLC stream multicast between 2 ports on my Fortiguard 310b V4. Wireshark and the fortigate sniffer show multicast traffic between my broadcasting computer1 and the Fortigate. But no traffic is being sent to my computer2, even though both are members of the same group, (224.15.1.1 ) --------------------------------------------------------------------- Interface: port1 Group: 224.15.1.1 Uptime: 00:32:22 Group mode: Exclude (Expires: 00:02:09) Last reporter: 192.168.1.6 Source list is empty Interface: port1 Group: 239.255.255.250 Uptime: 00:32:23 Group mode: Exclude (Expires: 00:02:12) Last reporter: 192.168.1.6 Source list is empty Interface: port2 Group: 224.15.1.1 Uptime: 01:08:01 Group mode: Exclude (Expires: 00:03:56) Last reporter: 192.168.2.6 Source list is empty Interface: port2 Group: 239.255.255.250 Uptime: 01:08:06 Group mode: Exclude (Expires: 00:03:57) Last reporter: 192.168.2.6 Source list is empty --------------------------------------------------------------- Here is my configuration Computer1: 192.168.1.6 on 192.168.1.99/24 Port1 Computer2: 192.168.2.6 on 192.168.2.1/24 Port2 //I have a normal firewall rule for Any to any both ways that lets me ping both ways. ------------------------ config system settings set multicast-forward enable end ------------------------ config firewall multicast-policy --edit 1 -----set dstintf " port2" -----set srcintf " port1" --next --edit 2 -----set dstintf " port1" -----set srcintf " port2" --next end -------------------------- //I also put PIM to see if that would help config router multicast --config interface -----edit " port1" --------set pim-mode dense-mode -----next -----edit " port2" --------set pim-mode dense-mode -----next --end ----set multicast-routing enable end --------------------------------- So both computers are members of the same group but the traffic is not being rebroadcast across the network. Any ideas what i' m doing wrong? Thank you
4 REPLIES 4
Newimage
New Contributor

Found my problem, the TTL not change was turned off config system settings set multicast-ttl-notchange enable
Heodrene

Hi Newimage, Have you keep your PIM configuration finally ? Regards, Heodrene
Jeff_the_Network_Guy
New Contributor III

For the record this implementation will also allow cross network Apple Airplay implementations. I was able to use this to get an iPad from one wireless network to connect to an AppleTV on another wireless network for presentations.
----------------(-- Jeff
----------------(-- Jeff
daveywavey
New Contributor

Hello Newimage and Jeff the Network Guy, Could you share some of your config on how you did this? I am struggling with trying to get Airplay working. Specially this part ----------------------------------------------------------------------------------------- Interface: port1 Group: 224.15.1.1 Uptime: 00:32:22 Group mode: Exclude (Expires: 00:02:09) Last reporter: 192.168.1.6 Source list is empty Interface: port1 Group: 239.255.255.250 Uptime: 00:32:23 Group mode: Exclude (Expires: 00:02:12) Last reporter: 192.168.1.6 Source list is empty Interface: port2 Group: 224.15.1.1 Uptime: 01:08:01 Group mode: Exclude (Expires: 00:03:56) Last reporter: 192.168.2.6 Source list is empty Interface: port2 Group: 239.255.255.250 Uptime: 01:08:06 Group mode: Exclude (Expires: 00:03:57) Last reporter: 192.168.2.6 Source list is empty ---------------------------------------------------------------------------------- Does mirroring work perfect or is it a little choppy? Thanks Davey
Forti OS 4.0: FLG_100B-v400-build0705 (4.3.7) FWF_80CM-v400-build0665 (4.3.15) Forti OS 5.0: FWF_90D-v500-build0228 (5.0.3)
Forti OS 4.0: FLG_100B-v400-build0705 (4.3.7) FWF_80CM-v400-build0665 (4.3.15) Forti OS 5.0: FWF_90D-v500-build0228 (5.0.3)
Labels
Top Kudoed Authors