Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
svl
New Contributor

MacOS Big Sur Fortclient VPN IPSec issues

Just installed macOS Big Sur and cannot get a connection with Fortinet firewall VPN anymore, while it did work with macOS Catalina.

 

I tried Forticlient version 6.4 which seems to connect just fine (I get an IP in expected range), but ssh/ping does not work. And also I cannot access a intranet http/https page.

 

Also tried multiple versions of 6.0.x but they all fail to connect and show "Connection was terminated unexpectedly. Error -104". After that, the keyboard (Macbook 16 inch) even fails to register any pressed buttons. For example I open app "notes" and cannot type anything (with every keystroke a sound is played but nothing is written). The only way to get out of this situation is to click "connect to VPN" in forticlient again and before it gets to the error click "disconnect". Then all works as usual (except the VPN obviously).

 

Anyone else having these issues?

 

Update Nov 25th 2020: 

Ok, so after quite a bit of testing by the people who maintain our firewall, we managed to make IPSec VPN work with native Mac OS Big Sur VPN client. I am always amazed by the lack of Fortinet response in this type of issues, as the solution seems pretty simple in the end. Eventually the configuration at fortigate firewall stayed exactly as it was, the only configuration I needed to add locally (with respect to using the FortiClient software) is to add a group name under "Authentication Settings". So to make it work we:

[ul]
  • Setup IPSec VPN in Mac OS Netwerk preferences (see also https://support.apple.com/guide/mac-help/set-up-a-vpn-connection-on-mac-mchlp2963/mac) using fields server address, account name (my personal account name), password (my personal account password) and under "Authentication settings" the shared secret (the shared password) and Group Name (had to get this from the firewall maintainer and never had to fill this in for FortiClient before).[/ul]

    Hopefully this helps others to get Fortigate IPSec VPN work with both Mac OS Big Sur and MacOS Catalina (both tested with our config).

  • 6 Solutions
    LJSilva
    New Contributor II

    If you're only using Forticlient to connect to your VPN, in macOS Big Sur you no longer need it. The built-in Cisco IPsec VPN of Big Sur will now connect and correctly establish a tunnel to your Fortinet VPN and it's very stable and reliable. I never managed to to this in Catalina, but it seems Apple may have corrected or changed the Cisco IPSec code in Big Sur and it's now working like a charm. I tried it yesterday and it worked flawlessly.

    View solution in original post

    Totoshka
    New Contributor II

    Kiran wrote:

    Same issue for me as well. Able to connect to IPSec VPN, but not able to open/connect to any internal URLs/Resources. And it's working fine for users with previous version of MacOS.

    The problem is similar. It all started after the update macOs Big Sur. 

     

     

     

    View solution in original post

    Kiran
    New Contributor II

    Yeah, But unfortunately when I reached out to support, they said that currently there is no supported version for MacOS 11 yet and will be available in future versions. So thought that better to suggest some alternative to people who are suffered like me, until the fix is release.

    View solution in original post

    kcerb
    New Contributor III

    Kiran wrote:

     

    Did you configure your IPSec VPN with Phase 1 - Local ID? When I tried native CISCO IPSec VPN, it did not work for VPN which is configured without Phase 1 - Local ID. Modify your VPN configuration with Phase 1 - Local ID and give it as 'Group Name'(which will be the option below the Shared Secret) while configuring the native VPN.

    You can add Local ID in native Mac OS VPN client (type: Cisco). Just click Authentication settings and type your LocalID in the Group Name field.

    FGT60B, FGT100A, FGT100D

    View solution in original post

    FGT60B, FGT100A, FGT100D
    mharwow
    New Contributor

    kcerb wrote:

    Kiran wrote:

     

    Did you configure your IPSec VPN with Phase 1 - Local ID? When I tried native CISCO IPSec VPN, it did not work for VPN which is configured without Phase 1 - Local ID. Modify your VPN configuration with Phase 1 - Local ID and give it as 'Group Name'(which will be the option below the Shared Secret) while configuring the native VPN.

    You can add Local ID in native Mac OS VPN client (type: Cisco). Just click Authentication settings and type your LocalID in the Group Name field.

    [attachImg]https://forum.fortinet.com/download.axd?file=0;191690&where=message&f=Setup-VPN-on-Mac-Linux-and-Windows.png[/attachImg]

    This solved the problem for me. I made an account just to say thanks. Once I filled out the Group Name I was connected. Hopefully my company supports the newer version of Fortinet in the future, but I'm happy to use the built-in VPN for now. 

    View solution in original post

    Bobbyla

    Just to confirm the VPN only installer is now updated on the website - Mac now connects using IPSEC on BigSur

     

    WOOHOO

     

    Thanks for updating it. (Labelled as 6.4 but when installing pulls the latest release 6.4.2.1.1305)

     

    Rob

     

    [image][/image]

    View solution in original post

    58 REPLIES 58
    superd
    New Contributor

    Hi,

    Has there been a fix / workaround here? Im running FC v7.0.1.0060 and Bigsur 11.6, with integrated Azure MFA SSO.

     

    remosito
    New Contributor

    we are seeing issue with big sur too.

     

    forticlient connects. even shows up on ipsec monitor page. 

     

    But no traffic goes through the tunnel

    Kiran
    New Contributor II

    Same issue for me as well. Able to connect to IPSec VPN, but not able to open/connect to any internal URLs/Resources. And it's working fine for users with previous version of MacOS.

    Totoshka
    New Contributor II

    Kiran wrote:

    Same issue for me as well. Able to connect to IPSec VPN, but not able to open/connect to any internal URLs/Resources. And it's working fine for users with previous version of MacOS.

    The problem is similar. It all started after the update macOs Big Sur. 

     

     

     

    Kiran
    New Contributor II

    https://support.apple.com/guide/mac-help/set-up-a-vpn-connection-on-mac-mchlp2963/mac

    I tried 'Enter VPN settings manually' in this doc and it worked for our IPSec VPN.

    Until the FortiClient IPSec VPN issue with the latest MacOS is fixed you guys can try this Cisco IPSec VPN available in MacOS Big Sur.

    Totoshka
    New Contributor II

    Kiran wrote:

    https://support.apple.com/guide/mac-help/set-up-a-vpn-connection-on-mac-mchlp2963/mac

    I tried 'Enter VPN settings manually' in this doc and it worked for our IPSec VPN.

    Until the FortiClient IPSec VPN issue with the latest MacOS is fixed you guys can try this Cisco IPSec VPN available in MacOS Big Sur.

    I think if there are alternatives, no one would write here  

    kcerb
    New Contributor III

    The built-in Cisco IPsec VPN of Big Sur works fine for me. It adds routes correctly so it works even if you have split tunnel enabled. DNS resolution work fine too. Now I won't be using the Fortinet client anymore - there have always been problems with it ...

     

    FGT60B, FGT100A, FGT100D

    FGT60B, FGT100A, FGT100D
    Kiran
    New Contributor II

    Yeah, But unfortunately when I reached out to support, they said that currently there is no supported version for MacOS 11 yet and will be available in future versions. So thought that better to suggest some alternative to people who are suffered like me, until the fix is release.

    spoonmanmx

    Hi.

     

    I need some different VPN, actually i have de forticlient connection over the fortigate, do i need to config cisco remote VPN over the fortigate unit?.

     

    Thank you so much. 

    gawbul

    Yes, having the same issue here. Had to install 6.2.7 first to connect to EMS and then upgrade to 6.4.1, but now can't connect to IPSec VPN. SSL VPN seems to work fine.

    Top Kudoed Authors