Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Georges_Orwell
New Contributor

Large depoyment of Forticlient whithout Fortigate

Hi guys, i look for solution to deploy forticlient on 300 Windows Workstations. i' ve tried to deploy it by GPO ( with msi installer) and using fcconfig.exe -m all -f c:\settings.xml -o import -i 1, but the result it was half a success. So, this method don' t work for me when the xml file is crypted by password. However i need and i want absolutly lock configuration of forticlient on target workstation. I' ve heard that it exist a possibility with .conf or .sconf file but i don' t know how to generate or build this kind of file. do any of you have the solution or have you heard of it? Georges Orwell
2 Solutions
kolawale_FTNT

See " Custom FortiClient Installations" starting from page 136 of the FortiClient Admin Guide: http://docs.fortinet.com/uploaded/files/1975/forticlient-admin-52.pdf It covers, among others, how to include a custom XML configuration file in the installer, before you deploy it with AD. Note that, with FortiClient 5.2.1, after running FortiClientConfigurator, any custom XML configuration file provided is saved in MST files. Be sure to load these along with the MSI file in the AD server.

View solution in original post

kolawale_FTNT

Hard to tell from your description what the current issues are. Lets assume the following:

 

    - you already ran FortiClient Configurator successfully

    - you uploaded a custom XML configuration file into the FortiClient Configurator

    - the Configurator generated an MSI and an MST file

 

As mentioned, your customisations are included in the MST file. The next steps are to create a GPO that includes both the MSI and MST files. Lets say the MSI file is already in the AD package. To add the MST file, see the Microsoft TechNet article: http://technet.microsoft..m/en-us/library/cc754879

 

The attached screenshot shows the MST file loaded in the modifications tab of the properties dialog box for the package.

View solution in original post

4 REPLIES 4
kolawale_FTNT

See " Custom FortiClient Installations" starting from page 136 of the FortiClient Admin Guide: http://docs.fortinet.com/uploaded/files/1975/forticlient-admin-52.pdf It covers, among others, how to include a custom XML configuration file in the installer, before you deploy it with AD. Note that, with FortiClient 5.2.1, after running FortiClientConfigurator, any custom XML configuration file provided is saved in MST files. Be sure to load these along with the MSI file in the AD server.
Georges_Orwell
New Contributor

Dear all,

 

I'm sorry but i created forticlient msi package with mst file using forticlientconfigurator.exe but when i deployed it on another computer it's default installation.

No configuration and no settings have been keeped from the template computer.

the steps in  the following documentation does not work in my case (Source configuration locked by password on template computer)  http://docs.fortinet.com/uploaded/files/1975/forticlient-admin-52.pdf

 

Has one of you already deployed a forticlient's customized package ?

 

Could you please post your install process for a large deployment?

 

Please help me , I'm desperate.

 

 

Thanks

 

Georges Orwell

kolawale_FTNT

Hard to tell from your description what the current issues are. Lets assume the following:

 

    - you already ran FortiClient Configurator successfully

    - you uploaded a custom XML configuration file into the FortiClient Configurator

    - the Configurator generated an MSI and an MST file

 

As mentioned, your customisations are included in the MST file. The next steps are to create a GPO that includes both the MSI and MST files. Lets say the MSI file is already in the AD package. To add the MST file, see the Microsoft TechNet article: http://technet.microsoft..m/en-us/library/cc754879

 

The attached screenshot shows the MST file loaded in the modifications tab of the properties dialog box for the package.

Georges_Orwell
New Contributor

Thank you so much.

 

It's work fine.