Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
patrickwilson82
New Contributor

LDAP too many DN's returned by user search

Hello,

We have a Fortimail unit that uses LDAP authentication for logging into the webmail for our quaratine folder. When I run an LDAP bind test on mu username and password, it tells me "Too many DNs returned by user search." So far my account is the only one I've ran across this issue on. It sounds like this is an issue with my AD. Any suggestions?

1 Solution
Dirty_Wizard_FTNT

Try a packet capture on port 389 on the FortiMail (assuming unencrypted) and see what DNs are returned.

The same mail attribute may be present on multiple users in AD.

View solution in original post

3 REPLIES 3
emnoc
Esteemed Contributor III

Did you do a search with another user? Can you set a filter ? Can you use  a tool like ldap.exe or curl and  search the object and see what's actually being sent ?

 

Ken Felix

PCNSE 

NSE 

StrongSwan  

PCNSE NSE StrongSwan
Dirty_Wizard_FTNT

Try a packet capture on port 389 on the FortiMail (assuming unencrypted) and see what DNs are returned.

The same mail attribute may be present on multiple users in AD.

patrickwilson82

jwilkins wrote:

Try a packet capture on port 389 on the FortiMail (assuming unencrypted) and see what DNs are returned.

The same mail attribute may be present on multiple users in AD.

That was it. I had my email as the mail attribute on more than one account in AD.

Top Kudoed Authors