Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
ArifS
New Contributor III

How to open ports

I want to access our backup software on port https 8015. I created virtual ip with source ip/port and dest ip/port. Created services with custom port 8015. Created policy to allow traffic on port 8015. But so far I am not able to access interface over internet. I also checked the logs and don't see any request hitting firewall. I created RDP access rule which is working fine. 

1 Solution
ArifS
New Contributor III

Issue resolved. The issue was in AWS security group which was only allowing port 443 and 3389. As soon as I allowed all traffic, I can access the server from outside through fortigate.

View solution in original post

6 REPLIES 6
sw2090
Honored Contributor

Basically to forward a port on a fgt you create a vip and set the neccessary values. Mostly setting the destination ip and port is enough. 

Then create a policy setting the required source and the vip as destination and probably allow the service.

 

Example:

 

you want to come from internet and access internal server 192.168.1.23 via 443/tcp (=https):

with the server connected to port1 and internet on wan1.

 

VIP:

 source ip: any

 destination ip 192.168.1.23

 source port 1-65535 

destination port 443

 

Policy:

 

allow wan1 to port1

source interface wan1

destination interface port1

source address all

destination address your vip from above

service HTTPS

and probably you might need to enable NAT here (not sure?)

 

 

-- 

"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

-- "It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams
ArifS
New Contributor III

Issue resolved. The issue was in AWS security group which was only allowing port 443 and 3389. As soon as I allowed all traffic, I can access the server from outside through fortigate.

parteeksharma

Hi ArifS,

Hope you are doing good.

To open the port from outside internet to inside DMZ of fortigate and access services based on that, you need to enable VIP port forwarding. Kindly check below link for VIP port forwarding:

https://community.fortinet.com/t5/FortiGate/Technical-Tip-Virtual-IP-VIP-port-forwarding-configurati...

Regards,
Parteek  

Olivia_7
New Contributor

RDP over the Internet requires port forwarding. You can follow this tutorial to forward the RDP port: Remote Desktop Port Forwarding If you are inaccessible outside the network, check the firewall settings and the antivirus software.

sareefbaccha61
New Contributor

To answer your question, you go into your router's port forwarding settings and set it to forward an external port to an internal IP and port. You probably knew this and are getting stuck in the process.

 pikashow.fyi

ppssppgold.one

ArifS
New Contributor III

Port forwarding through Fortigate worked after I opened AWS side ports. I can see the traffic whichever ports I open now.

Thank you everyone.

Top Kudoed Authors