Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
kloby
New Contributor

How to enabe logging to memory in CLI ?

Hi, After MR3 Patch 12, I cant enable log to memory in GUI, what is command to enable it over CLI ? And this " FortiCloud disk quota is 100% used" is worst than SPAM :) Disk Usage : 243 / 1024 MB on FortiCloud !?!
8 REPLIES 8
ede_pfau
Esteemed Contributor III

? like this:
 config log memory setting
     set diskfull overwrite
     set ips-archive disable
     set status enable
 end
 

Ede

"Kernel panic: Aiee, killing interrupt handler!"
Ede"Kernel panic: Aiee, killing interrupt handler!"
kloby
New Contributor

HI, Thanks for replay but it doesnt work, I cant enable " set status enable" . show log memory setting FG200Bxxxxxxx (setting) # get log memory setting diskfull : overwrite ips-archive : enable status : disable Im doing it on VDOM config
Fullmoon
Contributor III

I have the same problem no logs on my FG300C running on the same firmware

Fortigate Newbie

Fortigate Newbie
Dave_Hall
Honored Contributor

Currently prepping for moving our fgt devices from 4.0 MR3P7 to 4.0 MR3P11->4.0 MR3P12. So this logging thingy is kinda important. :-) I have loaded our base configs onto 2 x 80CM and 1 x 200B then upgraded the firmwares to P12 (in path recommended). No real problems with the 80CMs, but the 200B was a different matter. Received the following message (which is remorseless a duplicate message outlined in the patch notes)...
For optimal performance of your FortiGate unit, disk logging has been disabled during upgrade. It is recommended to enable logging to FortiCloud on this unit to utilize the extended logging & reporting capabilities.
Loading the config (before and after) into WinMerge, shows some minior adjustments to the wtp-profiles (adding what looks like country codes) and changing the 200B' s log file upload method to our FortiAnalyzer from store-and-upload to realtime. The log memory setting was also set to disable, but I was able to enable it without any issues...
# config log memory setting (setting) # show full-configuration config log memory setting set diskfull overwrite set ips-archive enable set status disable end (setting) # set status enable (setting) # show (setting) # show full-configuration config log memory setting set diskfull overwrite set ips-archive enable set status enable end (setting) #
But no logs were showing up in the GUI until I made the following change...
config log gui
     set log-device memory
 end
 
Dave

NSE4/FMG-VM64/FortiAnalyzer-VM/6.0 (FWF30E/FW92D/FGT200D/FGT101E/FGT81E)/ FAP220B/221C

NSE4/FMG-VM64/FortiAnalyzer-VM/6.0 (FWF30E/FW92D/FGT200D/FGT101E/FGT81E)/ FAP220B/221C
kloby

Its working now ! thanks man
fortigate2

My 60C with 5.0.2, can' t run " config log gui" and " config log memory setting" .
stephen_ren_FTNT

config log gui
conf sys admin edit admin set gui-log-display memory
ttinformatica

I have the same problem... when i have upgraded FGT 60c to 5.0.2 logs aren' t wrote visibles on shdc ! on gui i can' t show nothing Please help !
Top Kudoed Authors