Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
StangelmayerIT
New Contributor

Hard Token SN is invalid

Hello,

 

i have the following problem:

we purchased new Hard Tokens and i wanted to activate them in the fortigate. 

All i get is a Invalid serial number message.

I found the old problem with the Serial Number Checking Tool but this is failing too with a SN Not Found massage.

The SN are all starting with "FTK200BA8"

 

Is there a new chicking tool or do we have to contact our reseller?

 

Thanks in advance and greeting,

Dominik Gronau

1 Solution
xsilver_FTNT
Staff
Staff

I'm not aware of any new issue with token serial numbers at the moment.
Old issue you are referring to is probably the one fromCSB-121018-1 which is from 2012, where two batches of tokens had incorrectly printed SN from factory. Since then we had no such incident.

More common issue with invalid SN is with misinterpreted characters, like capital O and null 0.

Therefore I would strongly suggest to check serial numbers on the tokens. Or take the SN listing from order confirmation/shipment documents and copy&paste those.

If issue persist I would suggest to open technical trouble ticket via Fortinet's support portal, either as/through partner, or as end customer. And provide at least basic details like serial numbers of the tokens involved and some basic debug outputs.

Inspiration is here: https://community.fortinet.com/t5/FortiToken/Technical-Note-FortiToken-basic-troubleshooting/ta-p/19...

 

Tomas Stribrny - NASDAQ:FTNT - Fortinet stuff - TAC Staff Engineer

View solution in original post

3 REPLIES 3
xsilver_FTNT
Staff
Staff

I'm not aware of any new issue with token serial numbers at the moment.
Old issue you are referring to is probably the one fromCSB-121018-1 which is from 2012, where two batches of tokens had incorrectly printed SN from factory. Since then we had no such incident.

More common issue with invalid SN is with misinterpreted characters, like capital O and null 0.

Therefore I would strongly suggest to check serial numbers on the tokens. Or take the SN listing from order confirmation/shipment documents and copy&paste those.

If issue persist I would suggest to open technical trouble ticket via Fortinet's support portal, either as/through partner, or as end customer. And provide at least basic details like serial numbers of the tokens involved and some basic debug outputs.

Inspiration is here: https://community.fortinet.com/t5/FortiToken/Technical-Note-FortiToken-basic-troubleshooting/ta-p/19...

 

Tomas Stribrny - NASDAQ:FTNT - Fortinet stuff - TAC Staff Engineer

StangelmayerIT
New Contributor

Thanks for the advice with the shipment documents, that worked.

xsilver_FTNT

Good to hear it's fixed.

Probably some typo in token SN.


Hint:
HW token SNs are prefixed like FTK220 / FTK200 / FTK200B / FTK211.
FTK2 string is followed by double zero (with dots inside). This can be used to distinguish this number from uppercase "O" letter.

 

Another alternative just came to my mind .. you mentioned those are FTK200B .. and those have label on the back side containing not just SN, but also QR code (unfortunately a bit tiny one).

Tomas Stribrny - NASDAQ:FTNT - Fortinet stuff - TAC Staff Engineer

Top Kudoed Authors