Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
notrixx
New Contributor II

Fortios 7.0.x memory leak?

After upgrading our Fortigate 600E (two firewalls in HA) first to FortiOS 7.0.4 then later 7.0.5 we are experiencing what I suspect is memory leak issues.

 

Over time the memory usage goes up gradually to the point where the firewall goes into "conserve mode" and traffic forwarding stops. After reboot (HA failover) the memory usage is back down and then after about three weeks it goes into conserve mode again.

 

Anyone else experiencing the same problems?

Do you think I should just roll back to 6.4.x or wait for the next patch?

 

FG600e_mem_usage.PNG

 

 

 

1 Solution
notrixx
New Contributor II

The memory usage issues we experienced after upgrading from 6.4.x to 7.0.x seems to have been resolved with upgrading to 7.2.0 so I consider this case closed.

View solution in original post

33 REPLIES 33
ede_pfau
SuperUser
SuperUser

When I ran into these leak problems using v6.2.9, I had to install an auto-script to have the FGT kill processes when the conserve mode threshold was exceeded (so I could sleep at night). In this case, https processes were running wild, sometimes starting 17 at a time, with just 1 user logged on.

You can script on the FGT itself or on a FAZ.


Ede

"Kernel panic: Aiee, killing interrupt handler!"
Ede"Kernel panic: Aiee, killing interrupt handler!"
notrixx
New Contributor II

Tonight I upgraded the 600E's to FortiOS 7.2.0

In a couple of weeks I probably know if the memory leak issues are resolved.

Toshi_Esumi
Esteemed Contributor III

You mean "downgraded" from 7.2.5 to 7.2.0?

 

Toshi

notrixx
New Contributor II

Upgraded from 7.0.5 to 7.2.0

Wardensmith

FortiOS 7.0 expands visibility and control, ensures the consistent deployment and enforcement of security policies, and enables centralized management across the entire distributed network. For more details aslo see

https://community.fortinet.com/t5/Fortinet-Forum/Fortios-7-0-njlottery-x-memory-leak/m-p/208723

 

WiCS
New Contributor

The the memory leak issues are resolved with the upgrade to the 7.0.2? We have the same issue with 400E models.

 

notrixx
New Contributor II

 

I assume you mean upgrade to 7.2.0? Anyway.. it seems the upgrade has resolved the memory usage problem. I need a few more days to be absolutely sure but it seems fine now.

aproost
New Contributor

Is upgrading to 7.2.0 the solution?

notrixx
New Contributor II

The memory usage issues we experienced after upgrading from 6.4.x to 7.0.x seems to have been resolved with upgrading to 7.2.0 so I consider this case closed.

Mohammed-Mustafa
New Contributor II

I have upgraded to v7.2.2 but still receiving same problem!!!!

we need a solution to this!!!

Labels
Top Kudoed Authors