Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rcpdkc
Contributor II

Fortinac-F Vlan Switching

I'm using Fortinac-F ver 7.2.5.
SNMP
Ssh
Vlan
Although the configurations are correct and also the necessary rules are open, the switch cannot assign the user to the relevant vlan. It successfully assigns to the relevant vlan in the logs, but it does not change in the switch.

10 REPLIES 10
rcpdkc
Contributor II

In addition, I use Huawei Switch.
My settings are as follows:
Port default vlan100( also this nac eth1 isolation vlan)
Port link-type access

ndumaj
Staff
Staff

Hello,

What is the Huawei SW OID?
Did you auto added the SW into the inventory, is the correct mib matched for the Huawei SW you are using?
Does the VLAN change works when you do set manual vlan on the port of teh sw from FNAC Inventory Device port?
Try resync interface on the Huawei SW device.
Does the L2 poll works?

BR

- Happy to help, hit like and accept the solution -
rcpdkc
Contributor II

I added the devices with discovery. Ssh and SNMP information is correct. 

rcpdkc
Contributor II

When I manually send vlan from fortinac the vlan changes

ndumaj

Ok, on which scenario do you have issue?

How do you send the vlan change?

Is the host matching the policy?

Is the sw port member of role base access?

- Happy to help, hit like and accept the solution -
rcpdkc
Contributor II

The user enters information with persistent agent. Meanwhile, in Isolation vlan.( Vlan 100) . Later, in the fortinac interface, it appears that the user has switched to vlan 110, which is his own vlan. When I enter the logs, it seems to have switched from 100 to 110. However, the user is still fixed on vlan 100. Role-based access is open on the switch port.

ndumaj
Staff
Staff

Hi,
Unfortunately there is no guide for Huawei SW integration but it is easy basically chek only this part:
https://docs.fortinet.com/document/fortinac-f/7.2.0/huawei-wireless-integration/386277/model-the-dev...
See if you can successfully validate the credentials

BR

- Happy to help, hit like and accept the solution -
rcpdkc
Contributor II

When I do L2 pooling, the current description does not come. I correct the description and then I do pooling but it does not come again.

ndumaj

Under the Network - Inventory - Device --> polling menu whn you heit L2 poll now does the Last attempted poll and Last successful poll time updates??

Please send us a screenshot

- Happy to help, hit like and accept the solution -
Labels
Top Kudoed Authors