Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rezafathi
Contributor II

Fortigate DDNS

Hi

I want to enable ddns in fortigate but i can not select any servers in server list. How can i config ddns?

Reza F.
Reza F.
1 Solution
esalija
Staff
Staff

Hi @rezafathi 

 

You configure the DDNS and also from the CLI 

 

To configure DDNS servers other than FortiGuard in the CLI:
config system ddns
    edit <DDNS_ID>
        set monitor-interface <external_interface>
        set ddns-server <ddns_server_selection>
        set server-type {ipv4 | ipv6}
        set ddns-server-addr <address>
        set addr-type ipv6 {ipv4 | ipv6}
    next
end. 

 https://docs.fortinet.com/document/fortigate/7.4.1/administration-guide/685361/ddns

 

Best regards,

Erlin

View solution in original post

4 REPLIES 4
Toshi_Esumi
Esteemed Contributor III

What do you mean by "can not select"? Are those options dimmed? Is your DNS working, like pinging "www.google.com" from the FGT?

Toshi

DDNSsetting.png

esalija
Staff
Staff

Hi @rezafathi 

 

You configure the DDNS and also from the CLI 

 

To configure DDNS servers other than FortiGuard in the CLI:
config system ddns
    edit <DDNS_ID>
        set monitor-interface <external_interface>
        set ddns-server <ddns_server_selection>
        set server-type {ipv4 | ipv6}
        set ddns-server-addr <address>
        set addr-type ipv6 {ipv4 | ipv6}
    next
end. 

 https://docs.fortinet.com/document/fortigate/7.4.1/administration-guide/685361/ddns

 

Best regards,

Erlin

ozkanaltas
Contributor III

Hello @rezafathi ,

 

Maybe this can be related to your DNS setting. If you are not using FortiGuard DNS, this may be the reason. Could you check your Fortigate DNS settings?

If you have found a solution, please like and accept it to make it easily accessible to others.
NSE4-5-6-7 OT Sec - ENT FW
If you have found a solution, please like and accept it to make it easily accessible to others.NSE4-5-6-7 OT Sec - ENT FW
hbac
Staff
Staff

Hi @rezafathi,

 

Please note that configuring DDNS in the GUI is not supported if:

• The FortiGate model is a 1000-series or higher.
• The FortiGate is a VM.
• The DNS server is not using FortiGuard as the DNS.
• FortiGate does not support DDNS when in transparent mode.

 

You can try configuring in the CLI as suggested by esalija. 

 

Regards, 

Labels
Top Kudoed Authors