Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
rafaelbrsjtt
New Contributor

Forticlient VPN Only on Linux

Hi, recently i started an application on linux that i need to use a database on another network, so, i have to use a VPN to connect in this database.

 

 

When i run the command 'fortclient vpn view' i got the following message:

 

Client Certificate: None
Authentication: Disabled
Single Sign On (SSO) for VPN Tunnel: Disabled
Auto Connect: Disabled
Always Up: Disabled
Save Password: Disabled

 

 

How do i enable the option Always Up and Auto Connect?

 

the command 'forticlient vpn edit' don't give me this options.

 

Sorry for my bad english

 

 

 

 

1 Solution
ozkanaltas
Valued Contributor II

Hello @rafaelbrsjtt ,

 

You can enable with this command always-up feature. But you can't activate the auto-connect feature on Linux. Because the Linux client can't save your password. 

 

 

/opt/forticlient/fortivpn connect <my_vpn_name> --user=<username> --password --save-password --always-up

 

 

Also if you want to get more information about Linux client commands, you can review this document.

 

https://docs.fortinet.com/document/forticlient/7.2.4/administration-guide/41299/forticlient-linux-cl...

 

And I found one more thing. Someone wrote a script about automating ssl-vpn connection on Linux. I haven't try before but maybe it works for you.

 

https://gist.github.com/mgeeky/8afc0e32b8b97fd6f96fce6098615a93

 

If you have found a solution, please like and accept it to make it easily accessible to others.
NSE 4-5-6-7 OT Sec - ENT FW

View solution in original post

If you have found a solution, please like and accept it to make it easily accessible to others.NSE 4-5-6-7 OT Sec - ENT FW
1 REPLY 1
ozkanaltas
Valued Contributor II

Hello @rafaelbrsjtt ,

 

You can enable with this command always-up feature. But you can't activate the auto-connect feature on Linux. Because the Linux client can't save your password. 

 

 

/opt/forticlient/fortivpn connect <my_vpn_name> --user=<username> --password --save-password --always-up

 

 

Also if you want to get more information about Linux client commands, you can review this document.

 

https://docs.fortinet.com/document/forticlient/7.2.4/administration-guide/41299/forticlient-linux-cl...

 

And I found one more thing. Someone wrote a script about automating ssl-vpn connection on Linux. I haven't try before but maybe it works for you.

 

https://gist.github.com/mgeeky/8afc0e32b8b97fd6f96fce6098615a93

 

If you have found a solution, please like and accept it to make it easily accessible to others.
NSE 4-5-6-7 OT Sec - ENT FW
If you have found a solution, please like and accept it to make it easily accessible to others.NSE 4-5-6-7 OT Sec - ENT FW
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors