Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
yuno
New Contributor

FortiWifi in Wifi Client mode not connecting to the router

Hello all, I'm wondering if someone could please help me out with some info.

 

I'm having trouble connecting a FWF40C v5.2.4,build0688,150722 (GA) in Client Mode to another Wireless router.  Other devices (laptops/phones) can join the Wifi network fine, but I am apparently unable to connect the FWF40C to the router either on 5GHz or 2Ghz.  I've tried both WPA and WPA2, and the password is definately being entered correctly.  It just tries to connect with the little spinning wheel and then says "Not Connected".

 

As you can imagine googling for "Fortiwifi client not connecting" and similar searches brings up a lot of hits but I cant find anything specific to the problem I'm having.  That also suggests that I'm missing some simple but as yet I cant see it.  I've checked the FortiOS handbook and as far as I can see it should be working..

 

Does anyone know of any setting either on the Fortigate or potentially on the router that I might need to check?

 

Thanks very much

3 REPLIES 3
emnoc
Esteemed Contributor III

Suggestions;

 

Can you downgrade from 5.2.4 to 5.2.3 or even 5.0.12?

Does the status change if you downgrade?

 

 

PCNSE 

NSE 

StrongSwan  

PCNSE NSE StrongSwan
yuno
New Contributor

Hello, thanks for the reply.

 

I tried the 5.2.3 and 5.0.12 firmware versions but it still wouldn't connect unfortunately.  I checked 4 MR3 18 but it looks like the Client mode isn't supported there.

 

Any other thoughts on it?  I'll look into it but are you aware of any specific logging that is available that would help here?

 

Thanks

yuno
New Contributor

Got this working by creating a seperate SSID on the router set specifically to 5GHz, plus setting it to WPA2 (as opposed to WPA Auto).  I then set the radio on the Fortigate to use 5Ghz to match the SSID setting.  Prior to that I put it back up to firmware v5.2.4 and factory reset the unit.

 

Cheers

Top Kudoed Authors