Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
NeoRant
Contributor

FortiClient interrupting BUEXEC backups on exchange server

Good day all,

 

Is it safe to say tha the bad boy here is the Forticlient installed on my exchange server?

 

Full and incremental backups started failing immediately after installing FortiClient. Before though, my buexec normally has errors during backups, hit and miss, a few days backup fails due to some weird errors or communication errors, other days successful backups with no interruption. I cannot say however that it is definitely the FortiClient causing now CONSTANT failed backups, but i think it is. Kindly see attached resources for more information let me know what you think:

1. FortiClient on email server

2. https://www.veritas.com/support/en_US/article.100043312 - Look on Possible Causes #4

Fortiblockbuexec.jpg

3. Fortinet Community post sharing an almost similar issue - (https://community.fortinet.com/t5/Support-Forum/Backup-Exec-not-copying-servers-with-Forticlient-AV-...)

 

Any possible solution?

1 Solution
NeoRant

Good day team,

 

I JUST WANT TO SAY THAT I LOVE THIS COMMUNITY AND APPRECIATE EVERYONE, VERY HELPFUL YOU ALL ARE.

 

Well, what i have done is restarting the exchange server and backups completed successfully. Full & incremental backups run well for like a few days, then intermittently, there will be fails and then success etc. I reviewed error IDs as per usual for veritas, but this may or may not even be a Forticlient issue. Could either be a BUEXEC bug or just network timeout issue. Still though, I have read reports where Forticlient disrupts backup operations for the server endpoint it is installed on. So far, backups were running fine days before after then server restart, but this morning, i saw an incremental fail. As i said, intermittent drama.

View solution in original post

7 REPLIES 7
Anthony_E
Community Manager
Community Manager

Hello Neorant,


Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible.


Thanks,

Anthony-Fortinet Community Team.
Jean-Philippe_P
Moderator
Moderator

Hello NeoRant,

 

We are still looking for an answer to your question.

 

We will come back to you ASAP.

 

 

Thanks,

Jean-Philippe - Fortinet Community Team
Jean-Philippe_P
Moderator
Moderator

@AEK@ozkanaltas@ede_pfau can you help with this please?

Jean-Philippe - Fortinet Community Team
NeoRant

Good day team,

 

I JUST WANT TO SAY THAT I LOVE THIS COMMUNITY AND APPRECIATE EVERYONE, VERY HELPFUL YOU ALL ARE.

 

Well, what i have done is restarting the exchange server and backups completed successfully. Full & incremental backups run well for like a few days, then intermittently, there will be fails and then success etc. I reviewed error IDs as per usual for veritas, but this may or may not even be a Forticlient issue. Could either be a BUEXEC bug or just network timeout issue. Still though, I have read reports where Forticlient disrupts backup operations for the server endpoint it is installed on. So far, backups were running fine days before after then server restart, but this morning, i saw an incremental fail. As i said, intermittent drama.

Jean-Philippe_P

Hello NeoRant,

 

That's so kind, thanks a lot for your words!

 

Regards,

Jean-Philippe - Fortinet Community Team
Anthony_E
Community Manager
Community Manager

Hello,

 

THANK YOU :)!!!

We really appreciate your words and we are as well super thankful for all your contributions :)!

I m glad to work with positive people like you :)!

 

Never hesitate if you need anything and we will be there!

 

Regards,

Anthony-Fortinet Community Team.
ede_pfau
SuperUser
SuperUser

OP,

I know the following will not be "the instant recipe to happiness" but still...

From what I see within the first seconds:

- FC installed on Windows Server

This needs justification. Although newer versions of FC seem to support MS Server it still is an endpoint tool.

You will want to check the mutual dependencies and what MS has to say about this:

https://docs.fortinet.com/document/forticlient/7.2.0/administration-guide/742268/microsoft-server

 

- FC is out of date

- backup agent is out of date (?, hopefully) as even FC knows about its vulnerabilities.

- vuln scans are running in the background, and probably should not run while backup is running.

- network connection is flaky even without FC installed. Might be a hardware issue, or the NIC driver, or, or, or. Needs to addressed first.

 

There are so many question marks in your setup that I wonder it runs at all. Maybe if you reconsider why / if you need the FC at all on the server, you could eliminate one possible root cause.

Ede Kernel panic: Aiee, killing interrupt handler!
Ede Kernel panic: Aiee, killing interrupt handler!
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors