Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Guy_L
New Contributor

FortiClient cannot configure routing tables on Kali Linux

Hi all!

I've been trying to use FortiClient to establish a VPN connection on my Kali Linux machine. The client works fine with Ubuntu on the same computer, but it fails with the same configuration in Kali. The Kali installation was fresh when I tried it, and with all the dependencies installed.

Here are the sslvpn logs in both machines for comparison:

  • Kali
[sslvpn:DEBG] dns:700 Disable DHCP auto DNS
[sslvpn:DEBG] dns:730 Set DNS server: x.x.x.x x.x.x.x
[sslvpn:DEBG] dns:760 Set DNS domain: xxxxxxxxxx
[sslvpn:DEBG] dns:790 NM reapply
[sslvpn:DEBG] dns:821 Setup VPN interface
[sslvpn:DEBG] dns:823 Set DNS server: x.x.x.x x.x.x.x
[sslvpn:DEBG] dns:853 Set DNS domain: xxxxxxxxxxx
[sslvpn:DEBG] dns:883 NM reapply
[sslvpn:DEBG] dns:898 Apply settings failed, try again after 1 sec
[sslvpn:DEBG] dns:898 Apply settings failed, try again after 1 sec
[sslvpn:DEBG] dns:898 Apply settings failed, try again after 1 sec
[sslvpn:DEBG] dns:151 Restart DNS service failed.
[sslvpn:DEBG] dns:161 Flush DNS cache failed.
[sslvpn:DEBG] route:99 route backup START
[sslvpn:DEBG] route:151 route backup DONE
[sslvpn:DEBG] route:237 begin route config
[sslvpn:DEBG] route:238 Remote IP: x.x.x.x
[sslvpn:DEBG] route:239 Local IP: x.x.x.x
[sslvpn:DEBG] route:240 Tunnel mode: Split tunnel
[sslvpn:DEBG] route:241 Exclusive routing: Disabled
[sslvpn:DEBG] route:299 Can't find dev for IP x.x.x.x (tun)
[sslvpn:EROR] vpn_connection:1303 Config routing table failed
[sslvpn:DEBG] dns:364 Restore DNS config
  • Ubuntu
[sslvpn:DEBG] dns:700 Disable DHCP auto DNS
[sslvpn:DEBG] dns:730 Set DNS server: x.x.x.x x.x.x.x
[sslvpn:DEBG] dns:760 Set DNS domain: xxxxxxxxxxxxxxxxx
[sslvpn:DEBG] dns:790 NM reapply
[sslvpn:DEBG] dns:821 Setup VPN interface
[sslvpn:DEBG] dns:823 Set DNS server: x.x.x.x x.x.x.x
[sslvpn:DEBG] dns:853 Set DNS domain: xxxxxxxxxxxxxxxxxxx
[sslvpn:DEBG] dns:883 NM reapply
[sslvpn:DEBG] dns:149 Restart DNS service successfully.
[sslvpn:DEBG] dns:159 Flush DNS cache successfully.
[sslvpn:DEBG] route:99 route backup START
[sslvpn:DEBG] route:151 route backup DONE
[sslvpn:DEBG] route:237 begin route config
[sslvpn:DEBG] route:238 Remote IP: x.x.x.x
[sslvpn:DEBG] route:239 Local IP: x.x.x.x

In the Kali sslvpn logs, the error happens when trying to configure the routing table.

I have also posted this image with journalctl logs from the Kali machine. There seems to be a problem with the Network Manager.

 

Thanks in advance.

12 REPLIES 12
fianitnz
New Contributor II

yes: sudo nmcli connection up vpn<tab>
press tabkey several times during the connect process

 

as soon as:

sudo nmcli connection up vpn(some data)
press enter

kpa
New Contributor II

I wrote a short script which should fix the problem. See my original answer :)

Regards, Konstantin
Regards, Konstantin
SteveH1
New Contributor II

Many Thanks Konstantin,

 

That worked perfectly. Totally awesome. :)

Top Kudoed Authors