Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Register244
New Contributor

FortiClient Software Inventory Reporting Uninstalled Application

An endpoint previously had a vulnerability for an application flagged by FortiClient vulnerability scan.

The application has since been uninstalled and the vulnerability is not being detected.

 

However the application is still showing in the Software Inventory. It has been a number of weeks and I can confirm multiple vulnerability scans have since been ran as expected.

 

This issue is occurring with multiple applications but for this application in particular I can see that a vulnerability is no longer detected. I cannot find any executables for the applications on the endpoint.

 

Along side uninstall is there anything else to do to ensure an application is removed from the Software Inventory?

 

If this is an issue is there a location I could provide the application name for further review? I'm curious if this is linked to Issue 73790 for 7.2.4 but just wanted to ensure I've covered all checks from my side.

 

Thanks

5 REPLIES 5
Anthony_E
Community Manager
Community Manager

Hello Register244,


Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible.


Thanks,

Anthony-Fortinet Community Team.
Anthony_E
Community Manager
Community Manager

Hello,

 

We are still looking for someone to help you.

We will come back to you ASAP.


Regards,

Anthony-Fortinet Community Team.
ebilcari
Staff
Staff

Are you sure the application is completely removed from the end host? You can try to export the application list as raw and check the application path to see if there is any remaining file in the end host.

- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.
Register244

Hi ebilcari,

 

Yes, the folders related to the applications have been deleted.

 

The applications CSV file has an entry for the applications on the endpoint (For example: C:\Program Files...) however I have confirmed the folders don't exist on the endpoint.

 

If I search for the applications using the Windows 'Search This PC'  feature no files or folders related to the applications are returned.

 

The applications are not listed in 'Add or Remove Programs' under Windows system settings.

 

Thanks

 

AEK

Hi

You are right, this looks much like bug id:

737970Software Inventory on EMS does not properly reflect software changes (adding/deleting) on Windows endpoints.

I'd also try search in registry editor if any residual info left by application, just in case.

AEK
AEK
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors