Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
AlexisK
New Contributor

FortiAP 221e client can not connect

Hello, I have a wifi printer Samsung ML-2165w  and it can't connect to the network provided by FortiAP 221e. I've tried to disable many options but all attempts were unfortunated. Even can't connect to open network. Printer can connect to other access points successfully. Could you please advice something?  Below is a log from dmesg.

Thank you

[11257.519816] [957.510] cpu1 wmi_event_debug: dev=wifi1 event_id=0x9028(WMI_PEER_STA_PS_STATECHG_EVENTID)
[11257.643880] [957.630] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] recv auth frame with algorithm 0 seq 1
[11257.643935] [957.630] cpu0 wmi_cmd_debug: ol_alloc_cookie dev=wifi0 cookie=cdc40e04 seq=139143 in_use=1 cmd_id=0x9022(WMI_PEER_CREATE_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.644015] [957.630] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] ieee80211_alloc_node: vap=0xc6ae8000, nodecount=2, ni=0xcc7c0000 ref=2, ni_bss_node=0xcc7c0000 bss_ref=2
[11257.644186] wireless_send_event:790 mlmsg cmd=0x8C02 event_len=18 skb.len=68 nlmsg_len=68 nlmsg_type=16 nlmsg_flags=0 nlmsg_seq=4439 nlmsg_pid=0 extra=
[11257.644221] [957.630] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] send auth frame seq 2 status 0
[11257.644295] [957.630] cpu0 wmi_cmd_debug: ol_free_cookie dev=wifi0 cookie=cdc40e04 seq=139143 in_use=2 cmd_id=0x9022(WMI_PEER_CREATE_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.644913] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] WPA or RSN ie: mc 8/16 uc 8/13 key 2 caps 0xc
[11257.644956] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] UAPSD bit settings from STA: 00
[11257.644979] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] deny assoc request, no ht caps in pure 802.11n mode
[11257.645083] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] station with aid 0 leaves (refcnt 2)
[11257.645117] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] ieee80211_sta_leave: 0xcc7c0000
[11257.645159] [957.640] cpu0 wmi_cmd_debug: ol_alloc_cookie dev=wifi0 cookie=cdc40e04 seq=139146 in_use=2 cmd_id=0x9024(WMI_PEER_FLUSH_TIDS_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.645213] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] node_cleanup: vap=0xc6ae8000, nodecount=2, ni=0xcc7c0000, ni_bss_node=0xcd453c00 bss_ref=4
[11257.645249] [957.640] cpu0 wmi_cmd_debug: ol_alloc_cookie dev=wifi0 cookie=cdc40aa4 seq=139147 in_use=3 cmd_id=0x9023(WMI_PEER_DELETE_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.645291] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] node_cleanup: vap=0xc6ae8000, nodecount=2, ni=0xcc7c0000, ni_bss_node=0xcd453c00 bss_ref=4
[11257.645317] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] node_cleanup sta_assoc cnt iv 0 ==> 0 ic 0 ==> 0
[11257.645349] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] _ieee80211_free_node sta_assoc cnt iv 0 ==> 0 ic 0 ==> 0
[11257.645370] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] station free
[11257.645400] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] _ieee80211_free_node: vap=0xc6ae8000, nodecount=2, ni=0xcc7c0000 ref=0, ni_bss_node=0xcd453c00 bss_ref=4
[11257.645433] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] node_cleanup: vap=0xc6ae8000, nodecount=2, ni=0xcc7c0000, ni_bss_node=0xcd453c00 bss_ref=4
[11257.645457] [957.640] cpu0 vap-01(wlan01): [00:15:99:ea:95:29] node_cleanup sta_assoc cnt iv 0 ==> 0 ic 0 ==> 0
[11257.645520] [957.640] cpu0 wmi_cmd_debug: ol_free_cookie dev=wifi0 cookie=cdc40e04 seq=139146 in_use=2 cmd_id=0x9024(WMI_PEER_FLUSH_TIDS_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.645555] [957.640] cpu0 wmi_cmd_debug: ol_free_cookie dev=wifi0 cookie=cdc40aa4 seq=139147 in_use=1 cmd_id=0x9023(WMI_PEER_DELETE_CMDID) if_id=1 vap=wlan01 peer_macaddr=00:15:99:ea:95:29
[11257.645667] [957.640] cpu0 wmi_event_debug: dev=wifi0 event_id=0x9038(WMI_FTNT_EXT_EVENTID) subtype=1 date_len=24
[11257.645701] [957.640] cpu0 wmi_event_debug: dev=wifi0 event_id=0x9038(WMI_FTNT_EXT_EVENTID) subtype=2 date_len=24
[11257.645721] wmi_unified_ftnt_wifi_ext_event_handler: WRONG FTNT WIFI EXT sub-event assoc resp -- invalid mac 00:15:99:ea:95:29
[11257.742258] [957.730] cpu1 wmi_event_debug: dev=wifi1 event_id=0x9028(WMI_PEER_STA_PS_STATECHG_EVENTID)

1 Solution
yzhang_FTNT

>>deny assoc request, no ht caps in pure 802.11n mode

Looks like you select radio mode as 11n_only or some other xxx_only modes, but your printer only support 11a or 11g.

View solution in original post

3 REPLIES 3
Toshi_Esumi
Esteemed Contributor III

I would get rid of the printer that doesn't support WPA2 right away. It seems to support only WPS. Must be very old one.

https://www.cnet.com/products/samsung-ml-2165w-printer-b-w-laser-ml2165wxaa/

 

So "Open" would be the only option for the security setting. Then I would try all possible band settings that matches the printer's support; 802.11g, 11n, 11b, 11n_g-only, 11g-only, 11n-only, which is all options 221E has. And would make sure it's not "channel-bonding" to like 40MHz.

 

Since you didn't mention about the controller I was assuming the 221E is behind an FortiGate. I don't know if you have all these options available at FortiCloud if that's the controller. It might be better to leave it on the AP that works and move that AP behind the FortiGate.

yzhang_FTNT

>>deny assoc request, no ht caps in pure 802.11n mode

Looks like you select radio mode as 11n_only or some other xxx_only modes, but your printer only support 11a or 11g.
AlexisK
New Contributor

Resolved. Switched AP to b/g/n mode and reboot

Labels
Top Kudoed Authors