Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.

FG-61F: "FortiSwitch Ports" does not show devices anymore in column "Device Information"

FG-61F, 6.4.5, several FortiSwitches connected via FortiLink.


Since today, the FortiSwitch Ports view does not show anymore any devices in the "Device information" column.

The "Device inventory" in the Web GUI (Dashboard, User&Devices) is empty as well.


Yet, if I check the device database with the CLI command


diag user device list


I can see that all devices are apparently still in the DB.


I like the device information in the GUI. How can I get that information back?


Interesting side info:


diag user device clear     <---  seems not to work at all...


fortipg # diag user device stats 509997 generation.seen 69192 generation.deletion 44 count 139 joined 0 create_failed 0 fd 5 hash 2048






New Contributor

I am also seeing this same behavior on FG60F after upgrading to 7.0.5 and a Fortiswitch running 7.0.3. I have also noticed that some devices will show under Fortiview Sources but not in DHCP monitor at all. 


Hi Team,


As stated before that is a known bug and there is a workaround until the fix is released:


A workaround is to set the max devices to the maximum value of the range.

conf system global
set user-device-store-max-devices <max value>
user-device-store-max-devices Enter an integer value from <20775> to <59359>
(default = <41551>)

The max value will depend on the FGT model/memory capacity. The above example shows 59359 as max value.

New Contributor III

Hello aahmadzada,


Thanks for the workaround.

It works (Tested on 40F and 100F in HA)

Learning fortinet....... :)
Learning fortinet....... :-)
New Contributor II

Sorry but this didnt hold up. It worked at first directly after setting the limit but now a couple of hours later its showing as empty again. Both topology and device information is empty as before.


Tested on a 60F.


As my colleague already mentioned, this will be fixed in later release. Another workaround in case the setting of the global user-device-store-max-devices is not helping would be to graceful shutdown the wad daemon : "You can restore the user-device-store with "diag test application wad 98" then wait some seconds and user-device-store is repopulated."

NSE 4/5/7

This is what worked for me. Fortigate 80F. I hope they fix the underlying issue at some point...

New Contributor III


Does anyone know if this issue is fixed in 7.0.6 Build 0366?

Learning fortinet....... :)
Learning fortinet....... :-)

Dear Kenneth,


yes this issue is fixed in 7.0.6


Best , Steffen

NSE 4/5/7



Running 7.0.6 but it does not seem to be fixed. running on a Cluster FG100F


I did an "diag test application wad 98"  and it seems info is comming back. but not sure for how long..





Hi Patrick,


I had a few cases for this and all feedback I received was, that it was working after the upgrade. Let's see if it happens again. In this case I would suggest to raise a ticket for further analysis,


Best , Steffen

NSE 4/5/7

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors