Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
pgeusen
New Contributor

DNS no longer works on Linux after migrating Firewalls

After replacing our Fortigates 100E with Fortigate 60F the DNS settings on our Ubuntu/Xubuntu workplaces no longers works. Windows PC's in the same VLAN have no issues with DNS.

 

When trying to ping form Ubuntu:

ping: adc001: Temporary failure in name resolution.

 

I have tried on multiple existing pc's but I have also installed new Ubuntu and then the same issue is there. 

What 

5 REPLIES 5
ebilcari
Staff
Staff

Based on your description it seems like a DNS suffix issue. Check if there is any configuration change on the new FGTs, you can find more information on this article.

- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.
pgeusen

When I try adc001.domain.local i get the sames response.

pminarik
Staff
Staff

Make packet captures of both and compare. DNS is ultimately quite simple, so you should be able to identify the difference.

[ corrections always welcome ]
pgeusen
New Contributor

When I send a ping from the Ubuntu PC I get no activity on the Fortigate. When I use the dig command I see activty but I see the following errors

 

  • Flags: 0x8182 Standard query response, Server failure 
  • Flags: 0x8183 Standard query response, No such name
pminarik

If the FortiGate doesn't even get the packet maybe it's going in a completely different direction?
Try checking the basics. (ARP, ping to gw IP, ping to some public IP, does the dst MAC of internet-bound packets match the FGT's MAC?, etc.)

[ corrections always welcome ]
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors