Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Console Not working

I have a FortiSwitch 108E-FPOE.  Its bran new.  I have a RJ-45 to USB Console cord.  I've tested the cord and it works great on my FortiGate 60e.  When I connect it to the switch (I use PUTTY, it doesn't error when I connect), I hit enter and nothing happens.  I reboot it while its connected and I get characters like this "$Y▒▒y▒▒Z▒▒[", instead of any boot messages.  I have already updated its firmware and it's running v6.4.1,build0411,200409 (GA).  I (unfortunately) did not check the console connection before the firmware update.


After updating the firmware through the IP, I tried to set it up as a Managed FortiSwitch.  Ss soon as I setup the FortiLink Interface, it was never heard from again.  I waited for several hours but it never connected to the forigate, I was never assigned an IP from it, through any of it's ports; I couldn't assign an IP to myself and get in through the default IP or through the subnet created from the ForiGate.... or anything I tried.  That is when I tried the console cord and found that nothing happened.


I reverted the config on the my FortiGate but still didn't hear anything from the switch.  I factory reset the swtich (using the button on the front).  It got an IP from the Fortigate, I could connect to the IP using HTTP, and setup the admin password again.  Still no console connection though.


So now I'm here, it works (sort of) until I try to set it up for a Managed Switch.  If I do that, the same thing happens. Either way, there is no Console connection at all.


Does this sound like an RMA issue or am I missing something in my ignorance?


Try to change the putty console speed to 115200



FortiSwitch default speed is 115200 baud, 8/N/1.


For the rest of your questions, please read the FortiSwitch User Manual (not the FortiGate Handbook) to get all the background information you need. It's available at


Not all ports on the FS-108 model are ste to "auto-fortilink" per default. Try the last one first (I couldn't resist), port8.


"Kernel panic: Aiee, killing interrupt handler!"
Ede"Kernel panic: Aiee, killing interrupt handler!"

live 89:

I did, unfortunately, same issue.



At first, console worked and I set port 1 to allow a FortiLink connection (from the switch handbook).  When that failed (as described above), I factory reset it and just used port 8.  Same thing happened.   Now console isn't working for any settings I've tried.  I may try another factory reset and see if I can get the console working again.  Unless reverting the firmware will help?

New Contributor III

Hey did you manage to resolve your issue connecting to console port? I have a similar issue, trying to console to a rugged 112d FortiSwitch. I have managed to console to other Fortiswitches with success so i am confident the console cable is good. 

New Contributor

The Fortiswitch Rugged 112D appears to have a different pinout for its console port. Normal console cables like the Cisco ones and the integrated USB ones provided by Fortinet dont work. You have to use to console cable that is provided in the box with the FSR-112D.


It's crazy. Why on earth would Fortinet do such a thing?


Cisco console cables are all 8 pins connected between both ends. I noticed the console cables came with FGT and FSW have less pins connected both ends, and not consistent. Depending on controller chips on the device, some might not like to see signals on those unconnected pins. I recently experienced some specific character changes with FS108F when I used a Cisco console cable, which doesn't happen to 224D. 




You can try with factory reset and test again or there is a MGMT port on the FSW. You can access the FSW through MGMT port.

Default mgmt port address is (Make sure ip is not changed).
Connect mgmt port on the FSW to laptop with ethernet cable.
Assign static ip on the computer Open cmd prompt and make sure is reachable.
Open putty and access FSW through SSH using

Waqas Arshad

Run below command for factory reset

FSW# execute factoryreset

Waqas Arshad
New Contributor

Encountered the same console access issue this morning. Two rugged 112d FortiSwitches with the same behavior.  I get a few scrambled characters on boot up and nothing after that.  Console settings exact match with documentation and I've done many console sessions with FortiSwitches before.  Factory reset does not help.


Also, with console cable connected, switch would not properly boot up after power cycle.  Power light would remain on but not the ports(no link at all). After disconnection of console cable the switch booted up properly. Two console cable tested with the same result.

Top Kudoed Authors