Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Rob_Goldman
Staff
Staff

Configure FortiLink Switch for L2Mac Events traps but disable link traps

I would like to be able to configure a ForrtiSwitch in link mode to send  L2Mac Events when a mac is added and or removed from a switch port, but I do not want LinkUp or LinkDown trap sent  for the same connection.  How do I enable L2Mac Events (mac-notification traps) but disable Link traps?

 

FG version 7.0.1.3

FSW version 7.4.1

 

My current config that sends a L2Mac Events via SNMP and the Link state trap is as follows:

FortiGate Config

show switch-controller global
config switch-controller global
set mac-aging-interval 30
set mac-retention-period 0
set mac-event-logging enable

 

FortiSwitch Config

config system snmp community
edit 1
set events cpu-high mem-low log-full intf-ip ent-conf-change
config hosts
edit 1
set ip <IP and mask>
next
end
set name "XXXXXXX"
set trap-v2c-status disable
next
end

 

config switch interface
edit "port2"
set native-vlan 721
set untagged-vlans 4093
set snmp-index 2
set log-mac-event enable
next
end

2 REPLIES 2
AEK
Honored Contributor II

Thanks

This is useful for integration with NAC solution.

 

AEK
AEK
ebilcari
Staff
Staff

have you tried leaving only this event (l2mac) under community configurations:

config system snmp community

    edit 1

        set events l2mac

Is the switch still sending the link state traps?

- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.
Labels
Top Kudoed Authors