Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
mchioare
New Contributor II

Config routing table failed on forticlient 7.4

Hello,

I have installed client version 7.4.0.1636 and I can't connect. It works for my colleagues. Neither the GUI nor the CLI part works for me. Here is the output from the CLI:

 

$ forticlient vpn connect test740 -u XXXXX
Connect VPN: test740
Password:
Status: Connecting...
Status: Disconnected
Notification: Config routing table failed
DONE.

On the log, I can read:
20240610 20:25:02.119 TZ=+0200 [sslvpn:DEBG] route:102 route backup START
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:154 route backup DONE
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:396 begin route config
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:397 Remote IP: XXX.XXX.XXX.XXX
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:398 Local IP: 10.XX.XX.XX
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:399 Tunnel mode: Full tunnel
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:400 Exclusive routing: Disabled
20240610 20:25:02.120 TZ=+0200 [sslvpn:DEBG] route:453 Can't find dev for IP 10.XX.XX.XX (tun)
20240610 20:25:02.120 TZ=+0200 [sslvpn:EROR] vpn_connection:1712 Config routing table failed

I am running an updated Ubuntu 22.04.4.

Best regards and thanks in advance,
MChioare

MChioare
MChioare
7 REPLIES 7
mchioare
New Contributor II

I tried to use the script posted on "https://community.fortinet.com/t5/Support-Forum/FortiClient-7-2-0-0644-not-connecting-since-update-o... without lucky. Not work for me.

MChioare
MChioare
hbac
Staff
Staff
mchioare
New Contributor II

Hello,

Thank you for the reference to the article. However, I do not have FortiGate installed, so I cannot execute those commands. I am not the administrator of my network. When I try to connect via Windows or Android, the VPN works, but it does not work with my Ubuntu 22.04.4. Therefore, I believe that this suggested solution does not apply to my case. Thanks anyway.

Best regards,
MChioare

MChioare
MChioare
AGU_HD
New Contributor

I'm having the same issue with one user.

 

Brand new up-to-date installation of windows 10.

Download the FortiClient 7.4 VPN installer from https://www.fortinet.com/support/product-downloads

When trying to connect to our FortiGate it's stuck on 'Connecting'.

Uninstall 7.4 and installed and old 7.03 offline installer I had laying around and that works. Connects right away.

So there's something wrong with the current 7.4 FortiClient VPN application.

mchioare
New Contributor II

Hello,

I tried installing the version forticlient_7.0.12.0370_amd64.deb from repo.fortinet, and the first surprise is that it does not have a GUI. Using the CLI method, I tried to get it to work but was unsuccessful. It tells me to check the log. Could you please let me know where the log is located in this version?

I also tried version 7.2 without success, encountering the same problem as with version 7.4.

Thanks anyway.

Best regards,
MChioare

MChioare
MChioare
AGU_HD
New Contributor

I had another user where Forticlient 7.4 doesn't work.

Older version 7.03 didn't work either.

 

Got it to work by installing the FortiClient from Microsoft Store and then setting up the VPN connection in the Windows Network Settings > VPN > Add VPN connection > Choose VPN Provider 'Forticlient' and enter your VPN settings.

mchioare
New Contributor II

Hello,

I must insist that I have no issues connecting on Windows or Android. The problem is with Linux. It does not work with FortiClient 7.0, 7.2, or 7.4, using the same configuration and credentials. Therefore, the solution you propose does not apply to my situation. Thank you for responding anyway.

Best regards,
MChioare

MChioare
MChioare
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors