Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Žydrūnas
New Contributor III

Can't edit, can't delete fortilink interface

Hello,

 

We are using FortiGate 61E v7.0.8 build0418.

And we want start using Forti switches but fortilink error stands in our way.

When i try to open default fortilink interface via GUI it gives me an error:

"Failed to load data."

ydrnas_0-1667543955374.png

We never used fortilink or fortiswitches so is doesn't have any references.

ydrnas_0-1667545521388.png

When i try to delete it:

Generic error

  • Switch interfaces can only be deleted from the switch interface table.
  • Command_cli_delete:6677 delete table entry fortilink unset oper error ret=-160.

ydrnas_2-1667544117669.png

 

Fortlink interface via GUI looks like so:

ydrnas_3-1667544352666.png

ydrnas_4-1667544411271.png

 

CLI: 

 

 

 

 # config system interface 

 # edit fortilink 

 # show
config system interface
    edit "fortilink"
        set vdom "root"
        set ip 169.254.1.1 255.255.255.0
        set allowaccess ping fabric
        set type hard-switch
        set device-identification enable
        set lldp-transmission enable
        set role lan
        set snmp-index 7
    next
end

 

 

 

I know a workaround is to disable fortilink interface and create another fortilink dedicated interface for physical port and it works, but i really want to fix or delete that default fortilink interface to not leave any trash in configuration.

There should be way how to fix it.

1 Solution
Žydrūnas
New Contributor III

Ok guys, i managed to solve it with Forti support help.
This was corrupted settings in configuration file.
I had one spare same model same FW FortiGate on the shelf compared both configuration files with Notepad++.


And added missing lines in appropriate lines in config file:

 

 

    edit "fortilink"
        set vdom "root"
        set fortilink enable
        set ip 169.254.1.1 255.255.255.0
        set allowaccess ping fabric
        set type hard-switch
        set lldp-reception enable
        set lldp-transmission enable
        set snmp-index 7
    next

 

 

 

 

 

config system virtual-switch
	edit "fortilink"
        set physical-switch "sw0"
    next
end

 

 

 

 

 

config system ntp
    set ntpsync enable
    set server-mode enable
    set interface "fortilink"
end

 

 

 

 

 

config system dhcp server
	edit 1
        set ntp-service local
        set default-gateway 169.254.1.1
        set netmask 255.255.255.0
        set interface "fortilink"
        config ip-range
            edit 1
                set start-ip 169.254.1.2
                set end-ip 169.254.1.254
            next
        end
        set vci-match enable
        set vci-string "FortiSwitch" "FortiExtender"
    next   

 

 

 

I hope it helps somebody experiencing same problem.

You configuration might be different so edit .conf  accordingly.

Also after editing and restoring configuration use command:

 

diag debug config-error-log read

 

To check for configuration errors. and fix them if found.

View solution in original post

6 REPLIES 6
manasac
Staff
Staff

Hi @Žydrūnas 

 

As per the Screenshot "Fortlink interface via GUI looks like so" , there is no "Dedicated to Fortiswitch" option enabled. The interface looks like its corrupted, edit the interface from CLI and enable Fortilink parameter. 

 

manasac_0-1667549050511.png

config system interface
edit "interface name"
set fortilink enable

end

 

After enabling fortilink on the interface, try to delete the interface. Let me know if this helped.

 

Manasa C
Žydrūnas
New Contributor III

Did it and now a i got a new error when i try to open WiFi & Switch Controller/FortiLink Interface:

 

 

ydrnas_0-1667557387831.png

ydrnas_3-1667557532586.png

 

And same error then i try to open Network/Interfaces fortilink interface:

 

ydrnas_4-1667557631329.png

 

 

 

 

 

Žydrūnas
New Contributor III

Ok guys, i managed to solve it with Forti support help.
This was corrupted settings in configuration file.
I had one spare same model same FW FortiGate on the shelf compared both configuration files with Notepad++.


And added missing lines in appropriate lines in config file:

 

 

    edit "fortilink"
        set vdom "root"
        set fortilink enable
        set ip 169.254.1.1 255.255.255.0
        set allowaccess ping fabric
        set type hard-switch
        set lldp-reception enable
        set lldp-transmission enable
        set snmp-index 7
    next

 

 

 

 

 

config system virtual-switch
	edit "fortilink"
        set physical-switch "sw0"
    next
end

 

 

 

 

 

config system ntp
    set ntpsync enable
    set server-mode enable
    set interface "fortilink"
end

 

 

 

 

 

config system dhcp server
	edit 1
        set ntp-service local
        set default-gateway 169.254.1.1
        set netmask 255.255.255.0
        set interface "fortilink"
        config ip-range
            edit 1
                set start-ip 169.254.1.2
                set end-ip 169.254.1.254
            next
        end
        set vci-match enable
        set vci-string "FortiSwitch" "FortiExtender"
    next   

 

 

 

I hope it helps somebody experiencing same problem.

You configuration might be different so edit .conf  accordingly.

Also after editing and restoring configuration use command:

 

diag debug config-error-log read

 

To check for configuration errors. and fix them if found.

Žydrūnas
New Contributor III

Ok guys, i managed to solve it with Forti support help.
This was corrupted/missing settings in configuration file. How this happen i don't have an idea.
I had one spare same model same FW FortiGate on the shelf compared both configuration files with Notepad++.

And added/edited missing lines in appropriate lines in config file:

    edit "fortilink"
        set vdom "root"
        set fortilink enable
        set ip 169.254.1.1 255.255.255.0
        set allowaccess ping fabric
        set type hard-switch
        set lldp-reception enable
        set lldp-transmission enable
        set snmp-index 7
    next
config system virtual-switch
	edit "fortilink"
        set physical-switch "sw0"
    next
end
config system ntp
    set ntpsync enable
    set server-mode enable
    set interface "fortilink"
end
config system dhcp server
	edit 1
        set ntp-service local
        set default-gateway 169.254.1.1
        set netmask 255.255.255.0
        set interface "fortilink"
        config ip-range
            edit 1
                set start-ip 169.254.1.2
                set end-ip 169.254.1.254
            next
        end
        set vci-match enable
        set vci-string "FortiSwitch" "FortiExtender"
    next

 

I hope it helps somebody experiencing same problem.

You configuration might be different so edit .conf  accordingly.

Also after editing and restoring configuration use command:

diag debug config-error-log read

To check for configuration errors. and fix them if found.

Žydrūnas
New Contributor III

dddd

Žydrūnas
New Contributor III

Test cant post