Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
lievendhaese
New Contributor

Bluescreen on Windows 10 with #Forticlient

I'm having issues with FortiClient (7.0.3.0193) on Windows 10 Enterprise (19044.1645) inside a virtual machine (VM-ware)

  • Installation of the Forticlient worked without issues.
  • Configuration of VPN is OK (identical config works on host).
  • Connection gets established according to Forticlient.

Once connected, every communication through the VPN (ping,...) crashes Windows with a blue screen.

  • Stop code: KMODE EXCEPTION NOT HANDLED
  • What failed: ndis.sys

On the host computer everything works without blue screen... Any idea how to solve this?

1 Solution
blaisephilip
New Contributor

The crash was reproducible on my workstation as well:
Windows 10.0.19044
FortiClient 7.0.5.0238
In my case, if the Siemens SIMATIC Automation Tool is installed, the crash becomes reproducible. https://support.industry.siemens.com/cs/de/en/view/98161300
Only a complete reinstall of Windows (including everything) was the solution - until now. (tool uninstall, reg. entry resets etc. did not help) According to a Siemens-forum, tweaking the registry might help, but did not in my case. Finally this comment solved my issue: https://support.industry.siemens.com/forum/us/en/posts/tia-portal-v17-conflict-with-vpn/262291/?page...

In case the added FortiClient NIC adapters have active usage of the SIMATIC Industrial Ethernet (ISO) protocol, at ca. 98% connection status Windows will crash because of an exception in ndis.sys. Solution: see Control Panel --> Network and Sharing Center --> Change adapter settings --> select a FortiClient adapter --> uncheck the entries for special protocol(s), in my case the "SIMATIC Industrial Ethernet (ISO)"
There might be other applications that utilize NIC management and couple a protocol usage to it, which may be a rare but recurring issue in some corporate environments. In case special protocols are in use, activate them only on a separate physical network interface (e.g. USB NIC) to avoid this issue and keep using special industrial applications.

View solution in original post

7 REPLIES 7
Anthony_E
Community Manager
Community Manager

Hello lievendhaese,

 

Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible.

 

Thanks,

Anthony-Fortinet Community Team.
Anthony_E
Community Manager
Community Manager

Hello lievendhaese,

 

I have found this documentation which can be helpful:

 

https://docs.fortinet.com/document/forticlient/7.0.3/windows-release-notes/22791/resolved-issues

 

Could you please tell me if it helped?

If not, we will find another solution to your question.

 

Regards,

Anthony-Fortinet Community Team.
Hendra3005
New Contributor

related to the problem obtained, has it been resolved?

agass1
New Contributor

I also have this issue, running 7.0.5.0238. Any solutions?

blaisephilip
New Contributor

The crash was reproducible on my workstation as well:
Windows 10.0.19044
FortiClient 7.0.5.0238
In my case, if the Siemens SIMATIC Automation Tool is installed, the crash becomes reproducible. https://support.industry.siemens.com/cs/de/en/view/98161300
Only a complete reinstall of Windows (including everything) was the solution - until now. (tool uninstall, reg. entry resets etc. did not help) According to a Siemens-forum, tweaking the registry might help, but did not in my case. Finally this comment solved my issue: https://support.industry.siemens.com/forum/us/en/posts/tia-portal-v17-conflict-with-vpn/262291/?page...

In case the added FortiClient NIC adapters have active usage of the SIMATIC Industrial Ethernet (ISO) protocol, at ca. 98% connection status Windows will crash because of an exception in ndis.sys. Solution: see Control Panel --> Network and Sharing Center --> Change adapter settings --> select a FortiClient adapter --> uncheck the entries for special protocol(s), in my case the "SIMATIC Industrial Ethernet (ISO)"
There might be other applications that utilize NIC management and couple a protocol usage to it, which may be a rare but recurring issue in some corporate environments. In case special protocols are in use, activate them only on a separate physical network interface (e.g. USB NIC) to avoid this issue and keep using special industrial applications.

lievendhaese

I am also using Siemens. But it did not matter if I used those protocols or not.
Disabling all protocols on the VPN adapter solved it.

 
 
Plachy

This actually worked for me! Thank you!

Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors