Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
NARTONIC
New Contributor

Backup DNS Failed in Ubuntu 22.04

Hi,

 

I recieve this error when I'm trying connecting

 

"Notification: Backup DNS failed" when I'm trying to connect.

 

What's the problem?

 

I installed the last version of Forticlient, I'm using Ubuntu 22.04

 

6 REPLIES 6
AEK
Honored Contributor

Hello

Probably it failed to backup your DNS context before injecting VPN's DNS server IP (?)

Try check which DNS servers is your client using before and after VPN connection, and after VPN disconnection, to see if it is updated as expected.

AEK
AEK
Sheikh
Staff
Staff

Hello @NARTONIC 

 

you can also check this discussion .

 

regards,

 

Sheikh

**If you come across a resolution, kindly show your appreciation by liking and accepting it, ensuring its accessibility for others**
kerya
New Contributor

I faced the same issue:

 

sudo tail -f   /var/log/forticlient/sslvpn.log :

 

20231209 18:05:50.952 TZ=+0200 [sslvpn:DEBG] vpn_connection:1349 Login process end on status: 0
20231209 18:05:50.952 TZ=+0200 [sslvpn:INFO] sslvpn:824 Login successful
20231209 18:05:50.998 TZ=+0200 [sslvpn:INFO] main:1456 State: Configuring tunnel
20231209 18:05:51.068 TZ=+0200 [sslvpn:DEBG] vpn_util:260 Get connection name: ????????? ?????????? 1
20231209 18:05:51.068 TZ=+0200 [sslvpn:DEBG] vif:98 Using nmcli to allocate tun device.
20231209 18:05:51.367 TZ=+0200 [sslvpn:DEBG] dns:274 Default route device name: enxc8f750b40f75
20231209 18:05:51.430 TZ=+0200 [sslvpn:DEBG] vpn_util:260 Get connection name: ????????? ?????????? 1
20231209 18:05:51.430 TZ=+0200 [sslvpn:DEBG] dns:286 DNS backup
20231209 18:05:51.496 TZ=+0200 [sslvpn:DEBG] vpn_util:234 Get auto DNS setting failed.
20231209 18:05:51.496 TZ=+0200 [sslvpn:EROR] vpn_connection:1634 Backup DNS failed

brendanb
New Contributor

I got this error as well, using version 7.2.2.0753 on 22.04.3 LTS.

 

Changing Wi-Fi networks worked for me. I don't know why that is, but it worked. I tethered to my phone and it worked, as did switching to my guest network.

 

The latter really doesn't make sense to me, but I'm not very knowledgeable in this area.

 

It's not possible that there's an issue with the network names or something, right? The one that doesn't work has a colon in it? Sounds like a bad idea but getting it on screen anyways.

andres_chandia
New Contributor

I had this problem for a couple of days, checking the logs I have found that my connection name was with strange characters replacing the accents and spaces, the original name in Spanish was "Conexión Cableada 2", I changed it to "cableate" and voilà, it worked as expected!! I hope this comment helps you to solve your problem.... good luck!!

 

UPDATE to clarify some stuff that may not be well explained...

 

By "my connection" I mean the connection from my computer to my internal network/router, in my case is a network cable connection.

If you have problems while connected to a WI-FI connection, so the SSID (the name of the wi-fi connection) may be the problem; check that the SSID has no accents or spaces...

victorforerocabarcas

I had this problem too, and it was the connection name with utf-8 characters (accents): "Red1 automática", when changed, it worked flawlessly

 

Labels
Top Kudoed Authors