Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Umesh
New Contributor II

policy Id is not showing

Hi All,

 

As usually I used to see policy ID in fortigate firewall but last few days Policy ID is not showing.

Anyone have any Idea on this.

Or how can I check whole policy ID in GUI.

 

Thank you 

10 REPLIES 10
sw2090
Honored Contributor

Per default you only se some policy number in gui but this is NOT the actual policy id!

If you want to see the actual policy id in gui you have to click the gear on the left side of the column header and select the field policy id there and apply this. Then gui will show you the actual policy id.


-- 

"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

Umesh
New Contributor II

Hi,

Could you please explain it thoroughly here.

sagha

Hi Umesh, 

 

you can view the policy ID as follow: 

 

1. Go to policy and objects

2. Click firewall policy

3. Right click and select the option for ID. 

sagha_0-1663058300043.png

 

Hope this helps. 


Thanks 

Shahan Agha

Umesh
New Contributor II

thank you 

sw2090
Honored Contributor

hm ok just found that in some Version of FortiOS there is only one ID column in gui though.

But I'll explain it thoough:

Policy_id1.png

This is what the Policy View in gui looks like on my 92D here in FOS 6.2.10. That's the latest FOS release available for a 92D. It only has the column ID which then is the policy ID. I guess you are missing this column.

 

So if you hoover your mouse over the "ID" Column header (or what is the most left column in your view) you will see a filter and a gear icon appear. Cllick the gear icon then:

 

Policy_id2.png

This will pop up the column selection. Check if "ID" is activated (green "v" left to it indicates this). If not cllick it to activate it and then click "Apply". Then the column should be there again.

Though I remember there is some FGT and/or FOS Versions that do have two ID columns in gui.  In this case there would be some column named "Policy ID" or similar in that menue too.


-- 

"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

vvarangoulis
Staff
Staff

Hello Umesh,

What sw2090 wrote is correct. On the top row in your policy list in the GUI, you right-click it and you when you scroll down you will see the option for IDs, you enable that and on the far left (usually) they appear. You can reorganize the columns from the top row with drag and drop if you want to have the policy ids in front.

The documentation below in the column paragraph, it mentions how to enable more information to be displayed in your firewall policies.

 

https://docs.fortinet.com/document/fortigate/6.0.0/handbook/172114/viewing-firewall-policies


Cheers

Please mark the posts as solved if you have no further queries
--VV--
syordanov
Staff
Staff

Hello Umesh,
Please find the screenshots bellow how to enable the "policy ID" column in GUI :

 

Policy_ID1.JPGPolicy_ID2.JPG

.
Umesh
New Contributor II

Thank you so much, I understood.

sw2090
Honored Contributor

you could btw also use the "reset table" option in that menue to reset the table back to factory default view.


-- 

"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams