Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Kaplan
Contributor

can not delelte on Fortimanager the fortilink interface

Dear People,

I hope somebody can help me.
I try to delete the fortilink interface.

If I use the checkbox

 

Where fortilink is used

VDOM    Referrer Type        Field
global    system ntp             interface
 
Kaplan_0-1646841292750.png

 

 
All DHCP Server are deactiveted
I can not delete the fortilink interface

Can somebody explain a solution?
Thanx in advance
9 REPLIES 9
Kaplan
Contributor

Problem is, if you deactivate the NTP Server with CLI

config system ntp
unset server-mode
end

The ListenInterface will not deleted and you can not delte fortilink interface

Kaplan_0-1646843444544.png

Is there any way to unlink the fortilink from NTP Listen Interface over CLI?

 

Toshi_Esumi
Esteemed Contributor II

What do you see under "config system ntp" now in CLI? I mean, you get in the 40F via CLI over SSH, or direct console.

 

Or, you ran the CLI script against Device DB and haven't pushed it to the 40F yet?

 

Toshi

elfaran_FTNT
Staff
Staff

hi kaplan.

 

from your screenshot, can you just switch the button "Enable NTP Server" so that it will be disabled from FortiManager? then push the config over to the FortiGate, wait until it is finished, then delete the fortilink from FortiManager and push the new changes again?

 

otherwise, you can as well just unset server-mode from FortiGate cli, delete fortinlink there and then retrieve the config back to FortiManager as of: https://community.fortinet.com/t5/FortiManager/Technical-Tip-FortiGate-is-Out-of-sync-on-Device-Mana...

Toshi_Esumi
Esteemed Contributor II

He, at least we, don't want to disable NTP. But just want to disable server-mode. 

 

I wouldn't try removing a hard-switch like fortilink from FMG. I regularly make those interface structure changes before registering any FGTs to FMG. Similar to elfaran's 2nd option.

 

By the way, don't forget to remove the DHCP server (by default, edit 2).

 

Toshi

Kaplan

my solution:

First Step:

config system dhcp server
purge
end

config system ntp
set server-mode enable
set interface "modem"
end

Second Step

config system ntp
unset server-mode
end

Last Step:

config system interface
delete "fortilink"
end

 

Thanx again Toshi, thats very nice to try to help,

Toshi_Esumi
Esteemed Contributor II

I still think you can eliminate the step2 by "set server-mode disable" in the step1. That's what I do through direct CLI to make 'a' port a normal port.

Kaplan

Dear Toshi,
i tested for you now

Kaplan_0-1647289950031.pngKaplan_1-1647289979900.png

 

 

Toshi_Esumi
Esteemed Contributor II

Did you use a CLI script and ran it against the device directly?

Kaplan

No not now. If there was something noticed, when you use "where  used", so it's not possible. In the past I have tried more then one time.