Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Carlos1
New Contributor

Stop Forticlient from Starting on startup

The company I work uses this garbage so unfortunately I cannot unninstall it. However I dont want it to start on startup and I cannot disable it. There is no FortiClient option on the taskmanager startup tab. How can I proceed?

12 REPLIES 12
AlexC-FTNT
Staff
Staff

If you can't disable/stop/access it, then unfortunately you can't stop it from starting up. It seems to be enforced through company's policy, and that makes it quite impossible to disable.
If you are allowed to stop it, then you may prevent it from starting up through msconfig > Services (or Startup).


- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -
Carlos1

It doesn't show on the msconfig preferences, and I'm using it on my personal comouter at home.

Debbie_FTNT
Staff
Staff

It might also be prevented from being disabled at startup if the FortiClient serves as AntiVirus at the same time, not just as VPN client.

+++ Divide by Cucumber Error. Please Reinstall Universe and Reboot +++
Carlos1

If that's the case you should still be able to disable it, since even anti virus can be disabled or turned off.

Wayne11
Contributor


@Carlos1 wrote:

The company I work uses this garbage so unfortunately I cannot unninstall it.


With such a choice of words, you don't really deserve an answer. Just because you don't understand what the FortiClient is for, to call it garbage is a bit brazen. Get in touch with your IT department with these words, let's see what they answer you. 

Carlos1

I'm using it on my personal computer at home, there is no excuse for it not allowing me to disable it on startup, if a someone makes a software that forces itself up on system start without giving you the choice to disable it on your own personal computer, then my choice of words was perfect.

Wayne11

So if it's your private device I'm wondering why you have installed a software you have no clue what for it is or how to configure it. I guess you have HomeOffice and your company IS has installed the FortiClient to let you access the company network. So it's again the company IS department you would have to get in touch because there is a reason why it's configured as it is.

Carlos1

I'm also leaving you this answer given by another user wich sums up perfectly this situation:

 

" I'm just using forticlient to vpn into work for occasional remote monitoring and don't expect to use it all that frequently. If anybody from Fortinet is reading, this sort of behavior from software is truly obnoxious and arrogant. Please don't assume users need or want your software running all the time. At a minimum, there should be an easy way to disable this from the GUI settings page. Better would be to additionally ask for permission first. I shouldn't have to waste 30 minutes tracking down an answer in the forums, or worse have to dig out the commands on my own if somebody else hadn't already done it. "

 

 

Yucchie
New Contributor

This is assuming you have the latest version of the software (7.0+). You can disable startup of the application by doing the following:

 

- Shut down the FortiClient software (This includes exiting the software, if it hides in the system tray)

- Open up Services (run command: services.msc)

- Find the Service "FortiClient Service Scheduler" or something similar to this service (Stop this service if necessary)

- Open the Service Properties and change the "Startup type" to "Manual"

- OK and close all dialogs

- Reboot to test

 

This should stop FortiClient from starting automatically