Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Nishad
New Contributor III

Row log backup error " command failed. Error code -1 "

hi,

 

I am trying to take row log backup of my primary Fortigate log disk. Fortigate failed to backup vdom root. 

 

Connect to ftp server 1x.xx.xx.x ... Error: Sending log file /var/log/root/rlog.xxxx to ftp server via vdom root failed. Please wait...

 

Connect to ftp server 1x.xx.xx.x ... Error: Sending log file /var/log/root/wlog.xxxx to ftp server via vdom root failed. Please wait...

 

Connect to ftp server 1x.xx.xx.x ... Error: Sending log file /var/log/root/wlog.xxxx to ftp server via vdom root failed. Command fail. Return code -1

 

 

 

Kindly help me.. Why this is happning.?

Regards,

Nishad

12 REPLIES 12
ede_pfau
Esteemed Contributor III

Please post the command you're using.

Does the FGT have a route to the target server?

Test this: can you "exec ping 1x.xxx.xxx.xxx" ?

Which source IP address is used (for some FGT initiated traffic you can set the source address).

 

From what I see here (which is quite few information) I'd guess the routing isn't correct.


Ede

"Kernel panic: Aiee, killing interrupt handler!"
Nishad
New Contributor III

Hi thx for the reply..

 

I am trying to take raw log backup to FTP. The command is as follows. 

execute backup disk alllogs ftp [xx.xx.xx.xx]:[xxxx] ftp_username ftp_password.

 

FGT has route for the ftp server and I am able to ping to it. some file were getting copied but files that are situated in vdom-root that files are not getting transferred to ftp. And at the end I am getting error "command failed, error code -1"  

Regards,

Nishad

ericlei
New Contributor

i got the same problem,already fix?

cyber_area

how to fix the problem? i got the same problem. help me

AtiT
Valued Contributor

Just to be sure - are you executing the backup command under the management vdom (root by default)?

AtiT
--------------------
NSE 8, CCNP R+S

vivianwu_FTNT

"exe backup disk alllogs" is per-vdom command.

 

make sure under root vdom you can ping your ftp server.  

 

for example:

### vdom1 can ping ftp 

B (vdom1) # exe ping 172.16.200.55 PING 172.16.200.55 (172.16.200.55): 56 data bytes 64 bytes from 172.16.200.55: icmp_seq=0 ttl=64 time=0.2 ms 64 bytes from 172.16.200.55: icmp_seq=1 ttl=64 time=0.2 ms

 

B (vdom1) # exe backup disk log ftp 172.16.200.55 root 123456 event Please wait...

Connect to ftp server 172.16.200.55 ... Sent log file elog.65533 to ftp server as event_FGT5HD3915800164_vdom1_20170210_083329 OK. Please wait...

Connect to ftp server 172.16.200.55 ... Sent log file elog.65534 to ftp server as event_FGT5HD3915800164_vdom1_20170209_234327 OK. Please wait...

Connect to ftp server 172.16.200.55 ... Sent log file elog.65535 to ftp server as event_FGT5HD3915800164_vdom1_20170208_234324 OK. Please wait...

Connect to ftp server 172.16.200.55 ... Sent log file elog.0 to ftp server as event_FGT5HD3915800164_vdom1_20170207_235322 OK.

 

 

 

 

 

ck888

HI,

 

I face the same issue, anyone of you fix it?

 

any debug command could troubleshoot.?

 

Thanks

vivianwu_FTNT

What is the fos version? Just make sure ftp server is reachable from the FGT management vdom. 

ck888

Hi Vivian,

 

There is no vdom enable. The FortiOS version is 6.2.7 and confirm the connection good from FGT to FTP server. 

 

It's not all log have the error, only certain log.

 

do you know any debug command could troubleshoot.?