pbarbieri
New Contributor III

PIM start up

Hi,

it is a period that I have some problem with PIM of my  Firewall Fortigate 600D and wish to share this post if someone else has had the same experience.

I have a network of seven firewall connected by LAN. All node are PIM dense mode enabled. When I change the configuration to one of these, at beginning, after booting,  some of multicast between the firewall updated and the other firewalls are missing. Everything is ok in term of client join , IGMP , policy etc. What I do to let it to run is simply disable /enable, in the dashboard, the multicast routing. After this all run perfectly. It seems  as the boot is not enough to restore a right situation or   disabling enabling multicast routing probably reset some ethernet ports. In the multicast forwarding mode instead I have never had this problem. Do you know some tricks that can add to the configuration to avoid this problem? Could it be a bag? 

thanks in advance for your support

3 Solutions
Anonymous
Not applicable

Hello @pbarbieri ,

 

Thank you for posting on Fortinet Community Forum. As per your query, I would suggest you follow the link below and you could be able to narrow down the issue.

 

https://community.fortinet.com/t5/FortiGate/Technical-Tip-How-to-troubleshoot-IGMP-and-PIM-Dense-Mod...

 

Thanks,

 

View solution in original post

pbarbieri
New Contributor III

I tried and everything seems ok but when after a configuration update PIM  do not deliver all multicast group even if all the tables and diagnostic are correct. The only solution is manually disable enable the port connected with the client switch (IGMP enabled). So I will try to resolve the problem with one script that disable enable the port when it start:

/////////////

config system auto-script
edit "restore"
set interval 1
set repeat 1
set start auto
set script "
config system interface
edit port1
set status down
set interval 5
set status up"
next
end

////////////////

View solution in original post

pbarbieri
New Contributor III

I have resolved with this script enable disable the port connected with the client igmp enabled. I disable and enable the firewall port and the PIM start to flood all the multicast packet

View solution in original post

3 REPLIES 3
Anonymous
Not applicable

Hello @pbarbieri ,

 

Thank you for posting on Fortinet Community Forum. As per your query, I would suggest you follow the link below and you could be able to narrow down the issue.

 

https://community.fortinet.com/t5/FortiGate/Technical-Tip-How-to-troubleshoot-IGMP-and-PIM-Dense-Mod...

 

Thanks,

 

pbarbieri
New Contributor III

I tried and everything seems ok but when after a configuration update PIM  do not deliver all multicast group even if all the tables and diagnostic are correct. The only solution is manually disable enable the port connected with the client switch (IGMP enabled). So I will try to resolve the problem with one script that disable enable the port when it start:

/////////////

config system auto-script
edit "restore"
set interval 1
set repeat 1
set start auto
set script "
config system interface
edit port1
set status down
set interval 5
set status up"
next
end

////////////////

pbarbieri
New Contributor III

I have resolved with this script enable disable the port connected with the client igmp enabled. I disable and enable the firewall port and the PIM start to flood all the multicast packet